summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Tardon <dtardon@redhat.com>2017-12-07 13:45:31 +0100
committerDavid Tardon <dtardon@redhat.com>2017-12-07 13:49:10 +0100
commitd21267b50321749e894f4cb792b14b832ccbd7a3 (patch)
tree87d32697549d06b3f651fcf0f9787ff8e8adac7c /configure.ac
parent3dacb5a430b879f22266c06f47d6b78502cb1af2 (diff)
allow to build online help too
Change-Id: I9b26f952dc681893b25712451535f4b539fd615d
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 91437559fbde..e2833c8bb7af 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1866,6 +1866,7 @@ AC_ARG_WITH(help,
Usage: --with-help build the old local help
--without-help no local help (default)
--with-help=html build the new HTML local help
+ --with-help=online build the new HTML online help
--with-help=common bundle common files for the local
help but do not build the whole help
],
@@ -4604,6 +4605,11 @@ if test -n "$with_help" -a "$with_help" != "no" -a $_os != iOS -a $_os != Androi
ENABLE_HTMLHELP=TRUE
AC_MSG_RESULT([HTML])
;;
+ "online")
+ ENABLE_HTMLHELP=TRUE
+ HELP_ONLINE=TRUE
+ AC_MSG_RESULT([HTML])
+ ;;
*)
SCPDEFS="$SCPDEFS -DWITH_HELP"
AC_MSG_RESULT([yes])
@@ -4614,6 +4620,7 @@ else
fi
AC_SUBST([ENABLE_HTMLHELP])
AC_SUBST(HELP_COMMON_ONLY)
+AC_SUBST([HELP_ONLINE])
dnl Test whether to include MySpell dictionaries
dnl ===================================================================