summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Tardon <dtardon@redhat.com>2017-12-05 12:43:30 +0100
committerDavid Tardon <dtardon@redhat.com>2017-12-07 13:43:08 +0100
commitc9904bdd5bf2645c9723a8135c5fbceadb6b9aed (patch)
treee87ae437508fc71877a2b97a565b34bbd1c24a89 /configure.ac
parent706429497eae9597aca5c2578045cb9b63762b3e (diff)
allow to build only HTML help
Change-Id: I4debf079be228e5ce5fae5f1a153f78800407a59
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 13 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index e8d1f6a9bfa7..91437559fbde 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1863,8 +1863,9 @@ AC_ARG_WITH(help,
can be used to bundle only the common part, .e.g help-specific icons.
This is useful when you build the helpcontent separately.])
[
- Usage: --with-help build the entire local help
+ Usage: --with-help build the old local help
--without-help no local help (default)
+ --with-help=html build the new HTML local help
--with-help=common bundle common files for the local
help but do not build the whole help
],
@@ -4594,16 +4595,24 @@ HELP_COMMON_ONLY=FALSE
if test -n "$with_help" -a "$with_help" != "no" -a $_os != iOS -a $_os != Android; then
BUILD_TYPE="$BUILD_TYPE HELP"
GIT_NEEDED_SUBMODULES="helpcontent2 $GIT_NEEDED_SUBMODULES"
- if test "$with_help" = "common" ; then
+ case "$with_help" in
+ "common")
HELP_COMMON_ONLY=TRUE
AC_MSG_RESULT([common only])
- else
+ ;;
+ "html")
+ ENABLE_HTMLHELP=TRUE
+ AC_MSG_RESULT([HTML])
+ ;;
+ *)
SCPDEFS="$SCPDEFS -DWITH_HELP"
AC_MSG_RESULT([yes])
- fi
+ ;;
+ esac
else
AC_MSG_RESULT([no])
fi
+AC_SUBST([ENABLE_HTMLHELP])
AC_SUBST(HELP_COMMON_ONLY)
dnl Test whether to include MySpell dictionaries