summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRene Engelhard <rene@debian.org>2018-01-13 16:02:52 +0000
committerThorsten Behrens <Thorsten.Behrens@CIB.de>2018-01-23 13:39:00 +0100
commitc7a1320593191e8359aa64d8e262948da085d358 (patch)
tree75429c2cc378f1a5e395636aee59098eec6e1ebc /configure.ac
parentecb5fcff336c8b0e5ad2503f0880c439a6c323a5 (diff)
check for boost/process/child.hpp in configure.ac if --enable-gtk3-kde5
Change-Id: Idcd2931415558b41f94eb12a01f350f1ab53d134 Reviewed-on: https://gerrit.libreoffice.org/48319 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Thorsten Behrens <Thorsten.Behrens@CIB.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 80ec735478a6..6edc010762de 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8706,6 +8706,10 @@ if test "$with_system_boost" = "yes"; then
[AC_MSG_ERROR(boost/shared_ptr.hpp not found. install boost)], [])
AC_CHECK_HEADER(boost/spirit/include/classic_core.hpp, [],
[AC_MSG_ERROR(boost/spirit/include/classic_core.hpp not found. install boost >= 1.36)], [])
+if test "x$enable_gtk3_kde5" = "xyes"; then
+ AC_CHECK_HEADER(boost/process/child.hpp, [],
+ [AC_MSG_ERROR(boost/process/child.hpp not found. install boost >= 1.64)], [])
+fi
CXXFLAGS=$save_CXXFLAGS
AC_LANG_POP([C++])
# this is in m4/ax_boost_base.m4