summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Weghorn <m.weghorn@posteo.de>2018-02-12 12:35:47 +0100
committerThorsten Behrens <Thorsten.Behrens@CIB.de>2018-02-18 02:23:19 +0100
commitbcc5790554f02d65b03eebcc47fb8859fcf44643 (patch)
treef46fee86652882c0cd3882c79e0a4b5afbbb2b25 /configure.ac
parent10496770a6c4ba870787f20a4f0948c30e3d59cd (diff)
tdf#115554: Use 'fakeroot' to build Debian packages
The command to create Debian packages must be run as root or faked to be run as root. The 'fakeroot' makes sure the command is run in an environment faking root privileges for file manipulation. This makes sure that file ownerships and permissions inside the created deb packages are correct. Using fakeroot instead of the custom "libgetuid" makes it unnecessary to care about internals of the underlying tools (like tar) and changes in those by ourselves. Change-Id: I2cbb203ab84f740377e535c1051c2b879779b164 Reviewed-on: https://gerrit.libreoffice.org/49597 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Michael Stahl <mstahl@redhat.com> Reviewed-by: Thorsten Behrens <Thorsten.Behrens@CIB.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f18fa31dce5d..74a0a4e6844b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7296,6 +7296,10 @@ if test "$enable_epm" = "yes"; then
if test "$DPKG" = "no"; then
AC_MSG_ERROR([dpkg needed for deb creation. Install dpkg.])
fi
+ AC_PATH_PROG(FAKEROOT, fakeroot, no)
+ if test "$FAKEROOT" = "no"; then
+ AC_MSG_ERROR([fakeroot needed for deb creation. Install fakeroot.])
+ fi
fi
if echo "$PKGFORMAT" | $EGREP rpm 2>&1 >/dev/null || \
echo "$PKGFORMAT" | $EGREP pkg 2>&1 >/dev/null; then