summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Stahl <mstahl@redhat.com>2013-04-19 00:06:28 +0200
committerMichael Stahl <mstahl@redhat.com>2013-04-19 00:30:13 +0200
commitb9e6bd790f99b9018ea0a594cca8efcb1709c5e7 (patch)
treeaa60fc43e040f1235a3741e585910f357eb851cf /configure.ac
parent5bdf9edc622b84319756ad45569ad7be1865cb4f (diff)
configure: try to make all PYTHON variables point to the same thing
Change-Id: Ifa6a22717d6911b1f5dd816144d3ee95a09879a3
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a70bfd219de0..8451b74b3ffa 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7499,6 +7499,10 @@ if test $enable_python = system; then
AC_MSG_ERROR([no usable python found])])
test -n "$PYTHON_CFLAGS" && break
fi
+ # let the PYTHON_FOR_BUILD match the same python installation that
+ # provides PYTHON_CFLAGS/PYTHON_LDFLAGS for pyuno, which should be
+ # better for PythonTests.
+ PYTHON_FOR_BUILD=$PYTHON
fi
dnl By now enable_python should be "system", "internal" or "no"