summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2016-03-04 17:08:08 +0100
committerStephan Bergmann <sbergman@redhat.com>2016-03-04 17:08:08 +0100
commit9055fb48402eaeb9ba876b7893e2f9a39fea06b1 (patch)
tree42be3cc7c12f4cd60da0ec0e6cc39609f68f47ef /configure.ac
parentaf662f323d864e47d6218a2a63700e13b6e907fa (diff)
clang-cl: Enable more warnings etc. (like in the Clang/GCC case)
Change-Id: Ia1fb09b89d3ccc3c7f4a11799f0d8eac99c6c7a9
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 32ecfcc72aa5..f45af613bef9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5990,7 +5990,7 @@ AC_SUBST(HAVE_THREADSAFE_STATICS)
dnl ===================================================================
dnl visibility and other gcc features
dnl ===================================================================
-if test "$GCC" = "yes"; then
+if test "$GCC" = "yes" -o "$COM_IS_CLANG" = TRUE; then
AC_MSG_CHECKING([whether $CC supports -fvisibility=hidden])
save_CFLAGS=$CFLAGS
CFLAGS="$CFLAGS -Werror -fvisibility=hidden"