summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Stahl <mstahl@redhat.com>2018-01-23 18:29:13 +0100
committerMichael Stahl <mstahl@redhat.com>2018-01-23 21:53:19 +0100
commit81a1882d62ca26a28f70289e0134f6b78f1c21f2 (patch)
tree99a3f8d8926ced4175aa9abdd43bcb13ca2392df /configure.ac
parent112c931ff3a7aa263481b659931dfd172e75aafc (diff)
configure: if WiLangId.vbs isn't found but is required, error out
Change-Id: I8a145c1024a522a17c6ac2bf961cb4f07f3e7be9
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 10 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index aec4c88f9e95..3de79ab4d192 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5340,9 +5340,16 @@ the Windows SDK are installed.])
if ! test -e "$WINDOWS_SDK_WILANGID" ; then
WINDOWS_SDK_WILANGID=$(cygpath -sm "C:/Program Files (x86)/Windows Kits/8.1/bin/$WINDOWS_SDK_ARCH/WiLangId.vbs")
fi
- if ! test -e "$WINDOWS_SDK_WILANGID" ; then
- AC_MSG_WARN([WiLangId.vbs not found - building translated packages will fail])
- add_warning "WiLangId.vbs not found - building translated packages will fail"
+ fi
+ if test -n "$with_lang" -a "$with_lang" != "en-US"; then
+ if test -n "$with_package_format" -a "$with_package_format" != no; then
+ for i in "$with_package_format"; do
+ if test "$i" = "msi"; then
+ if ! test -e "$WINDOWS_SDK_WILANGID" ; then
+ AC_MSG_ERROR([WiLangId.vbs not found - building translated packages will fail])
+ fi
+ fi
+ done
fi
fi
fi