summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThorsten Behrens <Thorsten.Behrens@CIB.de>2017-12-08 00:10:42 +0100
committerThorsten Behrens <Thorsten.Behrens@CIB.de>2017-12-09 16:31:03 +0100
commit7886de305809e265cd2126d39912147131d3a004 (patch)
tree2730ca91aec3db7631780924b0de3753ef9df2e0 /configure.ac
parent032a3e3713af3e308229bd8e1ada17d6d24072f3 (diff)
gpg4libre: check if we can really verify OpenPGP signatures
And disable unit tests otherwise Change-Id: I32e1d8d2f8b0013d9cb43b78a55d23a1a29a8e8d Reviewed-on: https://gerrit.libreoffice.org/46057 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Thorsten Behrens <Thorsten.Behrens@CIB.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 16 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index e216e5fd9617..449dfc1add54 100644
--- a/configure.ac
+++ b/configure.ac
@@ -133,9 +133,16 @@ dnl path location is git, so make sure we have it
if test -n "$mac_git_path" -a -x "$mac_git_path" -a "$mac_git_path" != "/usr/bin/git" ; then
mac_path="$mac_path:`dirname $mac_git_path`"
fi
+dnl a not so common but nevertheless quite helpful thing that may be in a fancy
+dnl path location is gpg, so make sure we find it
+ mac_gpg_path=`which gpg 2>/dev/null`
+ if test -n "$mac_gpg_path" -a -x "$mac_gpg_path" -a "$mac_gpg_path" != "/usr/bin/gpg" ; then
+ mac_path="$mac_path:`dirname $mac_gpg_path`"
+ fi
PATH="$mac_path"
unset mac_path
- unset git_mac_path
+ unset mac_git_path
+ unset mac_gpg_path
}
echo "********************************************************************"
@@ -10225,6 +10232,14 @@ if test "$_os" = "Linux" -o "$_os" = "Darwin" -o "$_os" = "WINNT" ; then
fi
ENABLE_GPGMEPP=TRUE
AC_DEFINE([HAVE_FEATURE_GPGME])
+ AC_PATH_PROG(GPG, gpg)
+ # TODO: Windows's cygwin gpg does not seem to work with our gpgme,
+ # so let's exclude that manually for the moment
+ if test -n "$GPG" -a "$_os" != "WINNT"; then
+ # make sure we not only have a working gpgme, but a full working
+ # gpg installation to run OpenPGP signature verification
+ AC_DEFINE([HAVE_FEATURE_GPGVERIFY])
+ fi
fi
AC_SUBST(ENABLE_GPGMEPP)
AC_SUBST(SYSTEM_GPGMEPP)