summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSamuel Thibault <sthibault@hypra.fr>2018-02-21 10:45:02 +0100
committerStephan Bergmann <sbergman@redhat.com>2018-02-22 09:27:40 +0100
commit6a9f851e54f416820c61baf8caa79e4d91c8c61f (patch)
treeaf1e10c64280aa2ae3dedbfe1b6b57ba84c488fd /configure.ac
parent795effff8de6485eb6c1c2c9a43fc37d57c0563a (diff)
gla11y: Use python interpreter decided by configure
configure uses $PYTHON to determine lxml availability, so the make rule should use the same instead of letting gla11y find a python interpreter through "env", in case e.g. $PYTHON is python3, and lxml is available in python3 but not in python (actually python2). Along the way, rather use PYTHON_FOR_BUILD for coherency. Change-Id: Ied4c05aca462cc16685c61f36b56bb9e8612d90e Reviewed-on: https://gerrit.libreoffice.org/50087 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 58451b4912c7..8b624c3ded46 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8154,7 +8154,7 @@ system)
SYSTEM_PYTHON=TRUE
AC_MSG_CHECKING([for python lxml])
- if $PYTHON -c "import lxml.etree as ET" ; then
+ if $PYTHON_FOR_BUILD -c "import lxml.etree as ET" ; then
PYTHON_LXML=TRUE
AC_MSG_RESULT([yes])
else