summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2018-02-21 14:51:01 +0100
committerStephan Bergmann <sbergman@redhat.com>2018-02-21 20:08:05 +0100
commit55b310e785ed5fbdfb2996764751334dbb6fecdd (patch)
tree12ef672cc889760ffe011027f5bf8aea8dedbc18 /configure.ac
parente07d741b61ddc8b13046ce6ea0c0921ce046a0cf (diff)
Use printf instead of echo, just in case
...$PRODUCTNAME happens to be -n (which is notoriously problematic with various versions of echo). Change-Id: I09dfb562689138aa0135982725bf2c254ce06e59 Reviewed-on: https://gerrit.libreoffice.org/50104 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 479968be94b9..58451b4912c7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -168,7 +168,7 @@ if test "$enable_release_build" = "" -o "$enable_release_build" = "no"; then
fi
AC_MSG_RESULT([$PRODUCTNAME])
AC_SUBST(PRODUCTNAME)
-PRODUCTNAME_WITHOUT_SPACES=$(echo "$PRODUCTNAME" | sed 's/ //g')
+PRODUCTNAME_WITHOUT_SPACES=$(printf %s "$PRODUCTNAME" | sed 's/ //g')
AC_SUBST(PRODUCTNAME_WITHOUT_SPACES)
dnl ===================================================================