summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorjan Iversen <jani@libreoffice.org>2018-01-04 18:17:43 +0100
committerjan Iversen <jani@libreoffice.org>2018-01-04 18:19:29 +0100
commit3584c954337a625c93dae692849a53b6793d5a1e (patch)
tree3f0457cd39d8d3ef685a151d60f944d0fd479009 /configure.ac
parent61be109b1c10df3ddbb27f2a398b121a7c977f30 (diff)
iOS disable gpgme
Disable gpgme called for passing parameters to configure, when called internally (to generate config_build etc). Update the distro-conf, with info on the different supported models Change-Id: I884c8638bf7b1c9fbc8ea4bdaa4dfca019857f45
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index f125bd980be9..ce7598305e54 100644
--- a/configure.ac
+++ b/configure.ac
@@ -633,6 +633,7 @@ darwin*) # Mac OS X or iOS
AC_MSG_NOTICE([sanitized the PATH to $PATH])
fi
if test "$host_cpu" = "arm64" -o "$enable_ios_simulator" = "yes"; then
+ build_for_ios=YES
_os=iOS
test_gtk=no
test_cups=no
@@ -4379,6 +4380,7 @@ if test "$cross_compiling" = "yes"; then
test $with_junit = no && sub_conf_opts="$sub_conf_opts --without-junit"
test -n "$TARFILE_LOCATION" && sub_conf_opts="$sub_conf_opts --with-external-tar=$TARFILE_LOCATION"
test "$with_system_icu_for_build" = "yes" -o "$with_system_icu_for_build" = "force" && sub_conf_opts="$sub_conf_opts --with-system-icu"
+ test "$build_for_ios" = "YES" && sub_conf_opts="$sub_conf_opts build_for_ios=YES"
sub_conf_opts="$sub_conf_opts $with_build_platform_configure_options"
# Don't bother having configure look for stuff not needed for the build platform anyway
./configure \
@@ -10120,7 +10122,10 @@ fi
AC_SUBST(ENABLE_PDFIUM)
SYSTEM_GPGMEPP=
-if test "$_os" = "Linux" -o "$_os" = "Darwin" -o "$_os" = "WINNT" ; then
+
+if test "$build_for_ios" = "YES"; then
+ AC_MSG_CHECKING([gpgmepp disabled due to iOS])
+elif test "$_os" = "Linux" -o "$_os" = "Darwin" -o "$_os" = "WINNT" ; then
dnl ===================================================================
dnl Check for system gpgme
dnl ===================================================================