summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2017-11-08 15:27:43 +0100
committerStephan Bergmann <sbergman@redhat.com>2017-11-08 15:28:20 +0100
commit657ead3c4d8770117067d5b05a3bdd6dddb75a8b (patch)
tree8e7d0dc832022e32f3e8011859744309aa5f00ec /configure.ac
parent871e420cbbd8afe064e7bbc0ed426db3b01fddfa (diff)
Add comment to eventually remove HAVE_GCC_ATTRIBUTE_WARN_UNUSED
Change-Id: I71da6641768f804b19e16c899232f33efd4a9ae9
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index fdd9c005fc1a..26cfb628e3e6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5904,6 +5904,8 @@ if test "$GCC" = "yes" -o "$COM_IS_CLANG" = TRUE; then
], [AC_MSG_RESULT([no])])
AC_LANG_POP([C++])
+ dnl Available in GCC 4.9 and at least in Clang 3.4 (which is the baseline
+ dnl for at least --enable-compiler-plugins according to README.md):
AC_MSG_CHECKING([whether $CXX supports __attribute__((warn_unused))])
AC_LANG_PUSH([C++])
save_CXXFLAGS=$CXXFLAGS