summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Stahl <mstahl@redhat.com>2017-04-10 11:38:31 +0200
committerMichael Stahl <mstahl@redhat.com>2017-04-10 13:42:48 +0200
commitfae4b8d79819e205b1746014c770d5fb13d86e22 (patch)
tree402f10891c0d49d36fe6c49663edccd0c21ed19a /configure.ac
parent6bd33bd263c6666824d0d540395a4df4ae7d1d7b (diff)
gbuild: revert to -O0 instead of -Og for GCC --enable-debug/dbgutil builds
Unfortunately -Og doesn't work as well as advertised, variables are optimized away too often. See thread at https://lists.freedesktop.org/archives/libreoffice/2017-April/077479.html Change-Id: I5fc141ea9c7c6931aaf8220c7abf6b413326049e
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 0 insertions, 18 deletions
diff --git a/configure.ac b/configure.ac
index af0ffd882039..8398aa334a0c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3750,7 +3750,6 @@ fi
HAVE_GCC_GGDB2=
HAVE_GCC_FINLINE_LIMIT=
HAVE_GCC_FNO_INLINE=
-HAVE_GCC_OG=
if test "$GCC" = "yes"; then
AC_MSG_CHECKING([whether $CC supports -ggdb2])
if test -n "$CLANGVER" -a 0"$CLANGVER" -le 30100; then
@@ -3801,22 +3800,6 @@ if test "$GCC" = "yes"; then
AC_MSG_RESULT([no])
fi
- # clang as of version 4.0.0 (trunk 289424) doesn't do this very well (missing locals, bad param info in stack frame)
- if test "$COM_IS_CLANG" != "TRUE"; then
- AC_MSG_CHECKING([whether $CC supports -Og])
- # Note that clang-3.1 reports a real error for this option
- # so we do not need a special case for clang<=3.1 as above.
- save_CFLAGS=$CFLAGS
- CFLAGS="$CFLAGS -Werror -Og"
- AC_LINK_IFELSE([AC_LANG_PROGRAM([[]], [[ return 0; ]])],[ HAVE_GCC_OG=TRUE ],[])
- CFLAGS=$save_CFLAGS
- if test "$HAVE_GCC_OG" = "TRUE"; then
- AC_MSG_RESULT([yes])
- else
- AC_MSG_RESULT([no])
- fi
- fi
-
if test "$host_cpu" = "m68k"; then
AC_MSG_CHECKING([whether $CC supports -mlong-jump-table-offsets])
save_CFLAGS=$CFLAGS
@@ -3833,7 +3816,6 @@ fi
AC_SUBST(HAVE_GCC_GGDB2)
AC_SUBST(HAVE_GCC_FINLINE_LIMIT)
AC_SUBST(HAVE_GCC_FNO_INLINE)
-AC_SUBST(HAVE_GCC_OG)
dnl ===================================================================
dnl Test the gcc version