summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEike Rathke <erack@redhat.com>2017-04-22 01:24:19 +0200
committerEike Rathke <erack@redhat.com>2017-04-26 19:48:18 +0200
commitfabad007c60958f2ff87e8f636ff6a798ad1f963 (patch)
treecc7b5c588235f251b71738b128bfaa0b3ce291b0 /configure.ac
parent1b471124df251011b0053900cb82ceb0f3d8be86 (diff)
Upgrade to ICU 59.1
Also regenerated all patches using make icu.genpatch (hence the .1 suffix that indicates the path level) as some hunks did not apply anyway and all now have the correct offset. Using genpatch may have the future benefit to yield smaller diffs between different versions of patches. Also prefixed all patch names with icu4c- for a cleaner listing. New patches introduced are prefixed with icu4c-59-... Change-Id: Ia83754b0823839887fce1a1d4ed04f8375b113c2 Reviewed-on: https://gerrit.libreoffice.org/36809 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Eike Rathke <erack@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 11 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index ca5d0cd6b0b7..beb41ddc7d1b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -9014,7 +9014,7 @@ SYSTEM_GENBRK=
SYSTEM_GENCCODE=
SYSTEM_GENCMN=
-ICU_MAJOR=58
+ICU_MAJOR=59
ICU_MINOR=1
ICU_RECLASSIFIED_PREPEND_SET_EMPTY="TRUE"
ICU_RECLASSIFIED_CONDITIONAL_JAPANESE_STARTER="TRUE"
@@ -9102,6 +9102,15 @@ else
ICU_CFLAGS="-I${WORKDIR}/UnpackedTarball/icu/source/i18n -I${WORKDIR}/UnpackedTarball/icu/source/common"
ICU_LIBS="-L${WORKDIR}/UnpackedTarball/icu/source/lib"
fi
+if test "$ICU_MAJOR" -ge "59"; then
+ # As of ICU 59 it defaults to typedef char16_t UChar; which is available
+ # with -std=c++11 but not all external libraries can be built with that,
+ # for those use a bit-compatible typedef uint16_t UChar; see
+ # icu/source/common/unicode/umachine.h
+ ICU_UCHAR_TYPE="-DUCHAR_TYPE=uint16_t"
+else
+ ICU_UCHAR_TYPE=""
+fi
AC_SUBST(SYSTEM_ICU)
AC_SUBST(SYSTEM_GENBRK)
AC_SUBST(SYSTEM_GENCCODE)
@@ -9113,6 +9122,7 @@ AC_SUBST(ICU_RECLASSIFIED_CONDITIONAL_JAPANESE_STARTER)
AC_SUBST(ICU_RECLASSIFIED_HEBREW_LETTER)
AC_SUBST(ICU_CFLAGS)
AC_SUBST(ICU_LIBS)
+AC_SUBST(ICU_UCHAR_TYPE)
dnl ==================================================================
dnl Breakpad