summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEike Rathke <erack@redhat.com>2017-05-29 16:25:37 +0200
committerEike Rathke <erack@redhat.com>2017-05-29 18:24:51 +0200
commitc43a9c0f3e752e03b0d8dd135f67926918d0fb0f (patch)
treef9cc0ca96a427e48024c0664e8622b046f804238 /configure.ac
parent681ae3dfd031ce26c44a1069efc660e4691b4045 (diff)
Re-enable building with ICU 59, tdf#108043 follow-up
After having reverted to internal ICU 58, still be able to build with ICU 59. Change-Id: If2cf651aaacee5f64bee737f9da140b913ebd510 Reviewed-on: https://gerrit.libreoffice.org/38154 Reviewed-by: Eike Rathke <erack@redhat.com> Tested-by: Jenkins <ci@libreoffice.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3b1e6a0f699c..5859ace22d44 100644
--- a/configure.ac
+++ b/configure.ac
@@ -9069,6 +9069,15 @@ else
ICU_CFLAGS="-I${WORKDIR}/UnpackedTarball/icu/source/i18n -I${WORKDIR}/UnpackedTarball/icu/source/common"
ICU_LIBS="-L${WORKDIR}/UnpackedTarball/icu/source/lib"
fi
+if test "$ICU_MAJOR" -ge "59"; then
+ # As of ICU 59 it defaults to typedef char16_t UChar; which is available
+ # with -std=c++11 but not all external libraries can be built with that,
+ # for those use a bit-compatible typedef uint16_t UChar; see
+ # icu/source/common/unicode/umachine.h
+ ICU_UCHAR_TYPE="-DUCHAR_TYPE=uint16_t"
+else
+ ICU_UCHAR_TYPE=""
+fi
AC_SUBST(SYSTEM_ICU)
AC_SUBST(SYSTEM_GENBRK)
AC_SUBST(SYSTEM_GENCCODE)
@@ -9080,6 +9089,7 @@ AC_SUBST(ICU_RECLASSIFIED_CONDITIONAL_JAPANESE_STARTER)
AC_SUBST(ICU_RECLASSIFIED_HEBREW_LETTER)
AC_SUBST(ICU_CFLAGS)
AC_SUBST(ICU_LIBS)
+AC_SUBST(ICU_UCHAR_TYPE)
dnl ==================================================================
dnl Breakpad