summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMarkus Mohrhard <markus.mohrhard@googlemail.com>2017-04-14 02:44:20 +0200
committerMarkus Mohrhard <markus.mohrhard@googlemail.com>2017-04-14 03:32:37 +0200
commitb7b159d79c2b4ec53915e0b9c3e28912c289a5ba (patch)
tree2510d25832202cfbc79378473b497540dd5a5500 /configure.ac
parent6f12914ddfb4d69c0267b206be654c875da17426 (diff)
remove the old collaboration feature based on telepathy
Change-Id: I1f08d6ef43b76e7bae41ac33bb954f506ae7c485 Reviewed-on: https://gerrit.libreoffice.org/36542 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Markus Mohrhard <markus.mohrhard@googlemail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac32
1 files changed, 0 insertions, 32 deletions
diff --git a/configure.ac b/configure.ac
index 4308d3081d3a..c70d28c2346c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1263,11 +1263,6 @@ libo_FUZZ_ARG_ENABLE(gio,
[Determines whether to use the GIO support.]),
,test "${enable_gio+set}" = set || enable_gio=yes)
-libo_FUZZ_ARG_ENABLE(telepathy,
- AS_HELP_STRING([--enable-telepathy],
- [Determines whether to enable Telepathy for collaboration.]),
-,test "${enable_telepathy+set}" = set || enable_telepathy=no)
-
AC_ARG_ENABLE(tde,
AS_HELP_STRING([--enable-tde],
[Determines whether to use TQt/TDE vclplug on platforms where TQt and
@@ -10112,32 +10107,6 @@ AC_SUBST([GTK_PRINT_LIBS])
dnl ===================================================================
-dnl Check whether the Telepathy libraries are available.
-dnl ===================================================================
-
-ENABLE_TELEPATHY=""
-TELEPATHY_CFLAGS=""
-TELEPATHY_LIBS=""
-
-AC_MSG_CHECKING([whether to enable Telepathy support])
-if test "$_os" != "WINNT" -a "$_os" != "Darwin" -a "$enable_telepathy" = "yes"; then
- ENABLE_TELEPATHY="TRUE"
- AC_DEFINE(ENABLE_TELEPATHY)
- AC_MSG_RESULT([yes])
- PKG_CHECK_MODULES( TELEPATHY, telepathy-glib >= 0.18.0 glib-2.0 gobject-2.0 gthread-2.0 gio-2.0 gtk+-2.0 >= 2.18.0 )
- TELEPATHY_CFLAGS=$(printf '%s' "$TELEPATHY_CFLAGS" | sed -e "s/-I/${ISYSTEM?}/g")
- FilterLibs "${TELEPATHY_LIBS}"
- TELEPATHY_LIBS="${filteredlibs}"
-else
- AC_MSG_RESULT([no])
-fi
-
-AC_SUBST(ENABLE_TELEPATHY)
-AC_SUBST(TELEPATHY_CFLAGS)
-AC_SUBST(TELEPATHY_LIBS)
-
-
-dnl ===================================================================
SPLIT_APP_MODULES=""
if test "$enable_split_app_modules" = "yes"; then
@@ -12712,7 +12681,6 @@ AC_CONFIG_HEADERS([config_host/config_oox.h])
AC_CONFIG_HEADERS([config_host/config_options.h])
AC_CONFIG_HEADERS([config_host/config_options_calc.h])
AC_CONFIG_HEADERS([config_host/config_test.h])
-AC_CONFIG_HEADERS([config_host/config_telepathy.h])
AC_CONFIG_HEADERS([config_host/config_typesizes.h])
AC_CONFIG_HEADERS([config_host/config_vcl.h])
AC_CONFIG_HEADERS([config_host/config_vclplug.h])