summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@collabora.com>2017-04-10 21:06:43 +0300
committerTor Lillqvist <tml@collabora.com>2017-04-10 22:04:32 +0300
commitb076e8f673d1714ee8b6f991eb2ca299b6fa8949 (patch)
treeb1c398072c5bf90a3afd2ea503e057826fb64d2d /configure.ac
parenta876f982a56c0bcc04667d55a53b05c90a8c3354 (diff)
Fix include and library paths for at least me
Despite that the HKLM/SOFTWARE/Microsoft/Microsoft SDKs/Windows/ v10.0/ProductVersion value is 10.0.15063, the headers and libraries we want are in the subdirectories called 10.0.14393.0, not 10.0.15063.0. Not sure if this is just because of the collection of Visual Studio versions I happen to have installed, and their order of installation, or always true. Instead of all the convoluted logic in configure.ac, it would make much more sense to just use the relevant vcvars64.bat or vcvars32.bat file and pick out the INCLUDE and LIB environment variables it sets, and mangle that. We already have a (misleadingly named) function to look for variables set by a .bat file, win_get_env_from_vsvars32bat(). Change-Id: I647ec1d0924ba4c743e4c16d2fa0a05014e0b2e3
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 8398aa334a0c..49480e87020f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3325,6 +3325,9 @@ find_ucrt()
PathFormat "$(win_get_env_from_vsvars32bat UniversalCRTSdkDir)"
UCRTSDKDIR=$formatted_path
UCRTVERSION=$(win_get_env_from_vsvars32bat UCRTVersion)
+ if test "$UCRTVERSION" = 10.0.15063.0; then
+ UCRTVERSION=10.0.14393.0
+ fi
else
AC_MSG_ERROR([No UCRT found])
fi
@@ -5191,6 +5194,8 @@ find_winsdk_version()
winsdklibsubdir=$regvalue
if test "$regvalue" = "10.0.14393"; then
winsdklibsubdir="10.0.14393.0"
+ elif test "$regvalue" = "10.0.15063"; then
+ winsdklibsubdir="10.0.14393.0"
fi
return
fi
@@ -5201,7 +5206,7 @@ find_winsdk_version()
find_winsdk()
{
# Args: $1 (optional) : list of acceptable SDK versions
- # Return value: $winsdktest
+ # Return value: From find_winsdk_version
unset winsdktest