summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKohei Yoshida <kohei.yoshida@collabora.com>2017-04-24 22:48:18 -0400
committerTor Lillqvist <tml@collabora.com>2017-04-25 07:19:49 +0200
commit53ec01b67eb3e7020800f92a63860d332e73b1dd (patch)
treed9e9e5c7aae85be4f350ab745db0d0f8348c2658 /configure.ac
parent8f254a45d78dee53764321244aca108e2a1d344c (diff)
Get the configure.ac to detect .NET framework 4.7.
Change-Id: Ic936be25c6d66dd6a73d101869d535684bf0d680 Reviewed-on: https://gerrit.libreoffice.org/36918 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Tor Lillqvist <tml@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 9 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index f1ff14131c0e..ca5d0cd6b0b7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5111,13 +5111,14 @@ find_al()
fi
done
- # TODO(davido): We need this additional check to detect 4.6.2
- # This should be made generic, though
- reg_get_value_32 "HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Microsoft SDKs/NETFXSDK/4.6.2\WinSDK-NetFx40Tools/InstallationFolder"
- if test -n "$regvalue" -a \( -f "$regvalue/al.exe" -o -f "$regvalue/bin/al.exe" \); then
- altest=$regvalue
- return
- fi
+ # We need this additional check to detect 4.6.2 or above.
+ for ver in 4.7 4.6.2; do
+ reg_get_value_32 "HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Microsoft SDKs/NETFXSDK/$ver/WinSDK-NetFx40Tools/InstallationFolder"
+ if test -n "$regvalue" -a \( -f "$regvalue/al.exe" -o -f "$regvalue/bin/al.exe" \); then
+ altest=$regvalue
+ return
+ fi
+ done
}
find_dotnetsdk()
@@ -5139,7 +5140,7 @@ find_dotnetsdk46()
{
unset frametest
- for ver in 4.6.2 4.6.1 4.6; do
+ for ver in 4.7 4.6.2 4.6.1 4.6; do
reg_get_value_64 "HKEY_LOCAL_MACHINE/SOFTWARE/Wow6432Node/Microsoft/Microsoft SDKs/NETFXSDK/$ver/KitsInstallationFolder"
if test -n "$regvalue"; then
frametest=$regvalue