summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Lohmaier <lohmaier+LibreOffice@googlemail.com>2017-05-02 17:18:34 +0200
committerMichael Stahl <mstahl@redhat.com>2017-05-12 22:03:11 +0200
commit2e399f32e7505bdcf855112d8a48ae0edefe5bbc (patch)
tree7dbabd2f9e746be9710731b08bc356af8e30e9f7 /configure.ac
parentb6dd4f355e1da89a798061ab99492da834287f94 (diff)
auto-turn with-ant-home into absolute path
Change-Id: I0b48f46256aa88486dd29b1d283fa8be1ef2dced Reviewed-on: https://gerrit.libreoffice.org/37189 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Michael Stahl <mstahl@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ce1d74182b09..6bf2fa6f339a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -11615,6 +11615,8 @@ if test "$ENABLE_JAVA" != ""; then
# AC_PATH_PROGS needs unix path
with_ant_home=`cygpath -u "$with_ant_home"`
fi
+ AbsolutePath "$with_ant_home"
+ with_ant_home=$absolute_path
AC_PATH_PROGS(ANT, [jakarta-ant ant ant.sh ant.bat ant.cmd],,$with_ant_home/bin:$PATH)
WITH_ANT_HOME=$with_ant_home
ANT_HOME=$with_ant_home