summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Ostrovsky <david@ostrovsky.org>2015-10-23 18:39:07 +0200
committerStephan Bergmann <sbergman@redhat.com>2015-10-25 15:02:44 +0000
commit4e3086da3e9873f53b5b9e1d5e511f9f77aaf62f (patch)
treed90b50de0479ab3f8e60e36a85ce448f36934d87 /configure.ac
parentbe114fd49371beb8877c1cf34b48319967458c8a (diff)
Remove Seamonkey based address book driver
Seamonkey based address book driver is based on pre-compiled libraries and is only used on Windows 32 bit. Remove it in favor of mork driver. Given that Seamonkey based mozab driver also provides Outlook and Outlook Express address book integration, that Windows-32-bit--only feature is lost for now. If necessary, support for that feature could be rewritten from scratch, in a way that would also work for Windows 64 bit. Change-Id: Ie1c125e692598bda999767c328c9e2262a2b82af Reviewed-on: https://gerrit.libreoffice.org/19560 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac38
1 files changed, 0 insertions, 38 deletions
diff --git a/configure.ac b/configure.ac
index 7f81a2e71b4e..ebf80f42b335 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1014,12 +1014,6 @@ AC_ARG_ENABLE(pch,
[Enables precompiled header support for C++. Forced default on Windows/VC build])
)
-AC_ARG_ENABLE(win-mozab-driver,
- AS_HELP_STRING([--enable-win-mozab-driver],
- [LibreOffice includes a driver to connect to Mozilla
- address books under Windows, to build with this version, use this option.])
-)
-
AC_ARG_ENABLE(epm,
AS_HELP_STRING([--enable-epm],
[LibreOffice includes self-packaging code, that requires epm, however epm is
@@ -3882,9 +3876,6 @@ if test -n "$enable_dbgutil" -a "$enable_dbgutil" != "no"; then
else
with_system_libgltf=no
fi
- if test "$enable_win_mozab_driver" = "yes"; then
- AC_MSG_ERROR([--enable-win-mozab-driver conflicts with --enable-dbgutil])
- fi
else
ENABLE_DBGUTIL=""
MSVC_USE_DEBUG_RUNTIME=""
@@ -8772,35 +8763,6 @@ fi
AC_SUBST(SYSTEM_OPENLDAP)
dnl ===================================================================
-dnl Check for mozilla ab connectivity for windows
-dnl ===================================================================
-
-if test "$_os" = "WINNT"; then
- AC_MSG_CHECKING([whether to enable build of Mozilla addressbook connectivity driver for Windows])
- if test "$enable_win_mozab_driver" = "yes" -a "$WITH_MINGW" != "YES" ; then
- if test "$BITNESS_OVERRIDE" = 64; then
- AC_MSG_ERROR([--with-win-mozab-driver and --enable-64-bit options are mutually exclusive])
- fi
- WITH_MOZAB4WIN=TRUE
- AC_MSG_RESULT([yes, internal (old windows mozab driver)])
- BUILD_TYPE="$BUILD_TYPE MOZ"
- MSVC80_DLLS="msvcp80.dll msvcr80.dll Microsoft.VC80.CRT.manifest"
- MSVC80_DLL_PATH=`cygpath -u "$TARFILE_LOCATION"`
- for dll in $MSVC80_DLLS; do
- if ! test -f "$MSVC80_DLL_PATH/$dll"; then
- AC_MSG_ERROR([can not find $dll in $MSVC80_DLL_PATH needed for the pre-built Mozilla libraries])
- fi
- done
- else
- AC_MSG_RESULT([no])
- WITH_MOZAB4WIN=
- fi
-fi
-AC_SUBST(WITH_MOZAB4WIN)
-AC_SUBST(MSVC80_DLLS)
-AC_SUBST(MSVC80_DLL_PATH)
-
-dnl ===================================================================
dnl Check for TLS/SSL and cryptographic implementation to use
dnl ===================================================================
AC_MSG_CHECKING([which TLS/SSL and cryptographic implementation to use])