summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2015-10-02 10:42:31 +0200
committerStephan Bergmann <sbergman@redhat.com>2015-10-02 10:59:34 +0200
commitefad388f756014a7df5ed6f8e4ce417d24e9aba9 (patch)
treed77903df3660fd064515c1a4537c30ef55dc52ec /configure.ac
parent2957be02c5c4847046b9d192c7a76717c8849559 (diff)
Clean up Make SHELL handling
* In configure.ac, honour a preset SHELL_BASH when determining SHELL_BASH (so it can be passed in via autogen.input). * For both toplevel "make" and per-module "cd $module && make", consistenly use the SHELL_BASH determined in configure.ac as the Make SHELL. (By moving the setting to a new, common soleng/gbuild/shell.mk. This also exports SHELL as an environment variable to sub-processes now; this exporting can probably be reverted if it is not what is actually wanted---but note that this exporting of an environment variable to sub-processes is unrelated to how nested invocations of $(MAKE) obtain their Make SHELL setting, see below.) * Remove the gb_SHELL override feature from solenv/gbuild/gbuild.mk; for one, it is unclear how it was intended to interact with setting SHELL=@SHELL_BASH@ in the toplevel Makefile; for another, overriding SHELL can be done globally via setting SHELL_BASH in autogen.input now. * Make treats SHELL specially, in that it never uses the SHELL environment variable to determine the Make SHELL variable. Instead, if this Make invocation, or any outer Make invocation it is nested in via calls of $(MAKE), was called with a SHELL=... command line argument, then that value is used (and otherwise the default is hardwired as /bin/sh). So, when calling nested invocations of $(MAKE) from the toplevel Makefile, pass down the current SHELL value via a SHELL=... command line argument via GMAKE_OPTIONS. (And further nested invocations of $(MAKE) will then automatically inherit the SHELL value given on the outer invocation's command line.) Change-Id: I67fa1b88e4e90d09456c1fcad2d082fdce3c019b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 8 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index bb8a0a5bb75f..8ab6089f7a93 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4519,6 +4519,7 @@ if test "$cross_compiling" = "yes"; then
lo.xcent.in \
instsetoo_native/util/openoffice.lst.in \
config_host/*.in \
+ solenv/gbuild/shell.mk.in \
sysui/desktop/macosx/Info.plist.in \
ios/lo.xcconfig.in) \
| (cd CONF-FOR-BUILD && tar xf -)
@@ -4956,10 +4957,12 @@ if test "$_make_ver_check" = ""; then
STALE_MAKE=TRUE
fi
-if test "$GNUMAKE_WIN_NATIVE" = "TRUE" ; then
- SHELL_BASH=$(cygpath -m $(which bash))
-else
- SHELL_BASH=`which bash`
+if test -z "$SHELL_BASH"; then
+ if test "$GNUMAKE_WIN_NATIVE" = "TRUE" ; then
+ SHELL_BASH=$(cygpath -m $(which bash))
+ else
+ SHELL_BASH=`which bash`
+ fi
fi
AC_SUBST(SHELL_BASH)
@@ -12995,6 +12998,7 @@ AC_CONFIG_FILES([config_host.mk
Makefile
lo.xcent
instsetoo_native/util/openoffice.lst
+ solenv/gbuild/shell.mk
sysui/desktop/macosx/Info.plist
ios/lo.xcconfig])
AC_CONFIG_HEADERS([config_host/config_buildid.h])