summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Lohmaier <lohmaier+LibreOffice@googlemail.com>2015-10-14 21:20:33 +0200
committerChristian Lohmaier <lohmaier+LibreOffice@googlemail.com>2015-10-14 21:24:52 +0200
commit8840a66faceb5ebff2e6021e9b14da691d420234 (patch)
tree36d9c4a00cd1df2cc643b57d79205be57368d71d /configure.ac
parent2d2d5d1a704aa6827657a73b395620009b04b3ea (diff)
allow using Android Studio with lldb to debug native part
and of course also for the Java part Using build-id linker flag allows lldb to map the installed .so to the non-stripped version on the buildhost. Also ndk-gdb supports specifying a different package name on the commandline, so no need for the error in configure anymore. Change-Id: If6887a27cc8ab15ee6ab612502cacf0a22ade737
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 0 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 98c2253b76e5..12fd51c2547c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -12311,10 +12311,6 @@ if echo "$host_os" | grep -q linux-android ; then
AC_MSG_RESULT([not set, using $ANDROID_PACKAGE_NAME])
else
- if test -n "$ENABLE_DEBUG" -a "$with_android_package_name" != "org.libreoffice" ; then
- AC_MSG_ERROR([The package name must be set
-to org.libreoffice when debugging, please avoid --with-android-package-name.])
- fi
ANDROID_PACKAGE_NAME="$with_android_package_name"
AC_MSG_RESULT([$ANDROID_PACKAGE_NAME])
fi