summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBjoern Michaelsen <bjoern.michaelsen@canonical.com>2015-10-16 12:15:55 +0100
committerBjörn Michaelsen <bjoern.michaelsen@canonical.com>2015-10-16 13:50:28 +0000
commit3cf557c12d27f1b2250e69a543136da098112d80 (patch)
treea4b988a42e3cef7a019f118914572063c0f73d37 /configure.ac
parente00697d9738196f11f331335b256d7bacc17277d (diff)
drop gconf integration as per ESC decision
Conflicts: shell/source/backends/gconfbe/gconfbackend.cxx Change-Id: I609ec83ec59f5ae8d3a8c9c09649695bfcb03b87 Reviewed-on: https://gerrit.libreoffice.org/19408 Reviewed-by: Björn Michaelsen <bjoern.michaelsen@canonical.com> Tested-by: Björn Michaelsen <bjoern.michaelsen@canonical.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac41
1 files changed, 0 insertions, 41 deletions
diff --git a/configure.ac b/configure.ac
index 12fd51c2547c..e5350de18aa1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1000,11 +1000,6 @@ AC_ARG_ENABLE(fetch-external,
[Disables fetching external tarballs from web sources.])
)
-AC_ARG_ENABLE(lockdown,
- AS_HELP_STRING([--disable-lockdown],
- [Disables the gconf integration work in LibreOffice.]),
-)
-
AC_ARG_ENABLE(pch,
AS_HELP_STRING([--enable-pch],
[Enables precompiled header support for C++. Forced default on Windows/VC build])
@@ -1198,11 +1193,6 @@ AC_ARG_ENABLE(sdremote-bluetooth,
[Determines whether to build sdremote with bluetooth support.
Requires dbus on Linux.]))
-AC_ARG_ENABLE(gconf,
- AS_HELP_STRING([--disable-gconf],
- [Determines whether to use the GConf support.]),
-,enable_gconf=yes)
-
AC_ARG_ENABLE(gio,
AS_HELP_STRING([--disable-gio],
[Determines whether to use the GIO support.]),
@@ -10004,24 +9994,6 @@ fi
AC_MSG_NOTICE([VCLplugs to be built: $build_vcl_plugins])
dnl ===================================================================
-dnl GCONF check
-dnl ===================================================================
-
-ENABLE_GCONF=
-AC_MSG_CHECKING([whether to enable GConf support])
-if test "$_os" != "WINNT" -a "$_os" != "Darwin" -a "$_os" != "iOS" -a "$enable_gconf" = "yes"; then
- ENABLE_GCONF="TRUE"
- AC_MSG_RESULT([yes])
- PKG_CHECK_MODULES( GCONF, gconf-2.0 gobject-2.0 )
- GCONF_CFLAGS=$(printf '%s' "$GCONF_CFLAGS" | sed -e "s/-I/${ISYSTEM?}/g")
-else
- AC_MSG_RESULT([no])
-fi
-AC_SUBST(GCONF_LIBS)
-AC_SUBST(GCONF_CFLAGS)
-AC_SUBST(ENABLE_GCONF)
-
-dnl ===================================================================
dnl check for dbus support
dnl ===================================================================
ENABLE_DBUS=""
@@ -11229,19 +11201,6 @@ AC_SUBST(KDE_GLIB_LIBS)
AC_SUBST(KDE_HAVE_GLIB)
dnl ===================================================================
-dnl Test for the enabling the lockdown pieces
-dnl ===================================================================
-AC_MSG_CHECKING([whether to enable the lockdown pieces])
-ENABLE_LOCKDOWN=
-if test -n "$enable_lockdown" -a "$enable_lockdown" != "no"; then
- ENABLE_LOCKDOWN=TRUE
- AC_MSG_RESULT([yes])
-else
- AC_MSG_RESULT([no])
-fi
-AC_SUBST(ENABLE_LOCKDOWN)
-
-dnl ===================================================================
dnl Test whether to include Evolution 2 support
dnl ===================================================================
AC_MSG_CHECKING([whether to enable evolution 2 support])