summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSamuel Mehrbrodt <Samuel.Mehrbrodt@cib.de>2015-09-29 14:30:45 +0200
committerSamuel Mehrbrodt <Samuel.Mehrbrodt@cib.de>2015-10-01 08:45:07 +0000
commit25de5cfa43b2b1cb7d7214470acc7719839e13fe (patch)
treef60b66a0c08ff04a627b396cc7047e282cce1309 /configure.ac
parent85f93697defd9a812a0cda0bc4e9364e28c0339e (diff)
autogen: Better check for USING_X11 instead of with_x in some cases
USING_X11 includes os defaults, while with_x is only the option explicitly set by the user Change-Id: I7933b038805a87c418404b40f513c4491e11fd8f Reviewed-on: https://gerrit.libreoffice.org/18919 Reviewed-by: Samuel Mehrbrodt <Samuel.Mehrbrodt@cib.de> Tested-by: Samuel Mehrbrodt <Samuel.Mehrbrodt@cib.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 5 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 946aa79e0766..bb8a0a5bb75f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4341,7 +4341,6 @@ mingw*)
;;
*netbsd*)
-
COM=GCC
USING_X11=TRUE
OS=NETBSD
@@ -4401,7 +4400,6 @@ openbsd*)
;;
solaris*)
-
COM=GCC
USING_X11=TRUE
OS=SOLARIS
@@ -4679,13 +4677,12 @@ if test $_os != "WINNT" -a $_os != "Darwin"; then
fi
AC_SUBST(ENABLE_OOENV)
-if test "$with_x" = "no"; then
- # be sure to do not mess with uneeded stuff
+if test "$USING_X11" != TRUE; then
+ # be sure to do not mess with unneeded stuff
test_randr=no
test_xrender=no
test_cups=no
test_dbus=no
- test_fontconfig=yes
test_gtk=no
build_gstreamer_1_0=no
build_gstreamer_0_10=no
@@ -9224,7 +9221,7 @@ AC_MSG_CHECKING([whether to use X11])
dnl ***************************************
dnl testing for X libraries and includes...
dnl ***************************************
-if test $USING_X11 = TRUE; then
+if test "$USING_X11" = TRUE; then
AC_DEFINE(HAVE_FEATURE_X11)
fi
AC_MSG_RESULT([$USING_X11])
@@ -10020,7 +10017,7 @@ dnl Test which vclplugs have to be built.
dnl ===================================================================
R=""
AC_MSG_CHECKING([which VCLplugs shall be built])
-if test "$USING_X11" != TRUE -o "$with_x" = "no"; then
+if test "$USING_X11" != TRUE; then
enable_gtk=no
enable_gtk3=no
fi
@@ -10394,7 +10391,7 @@ elif test $_os = WINNT; then
SYSTEM_MESA_HEADERS=
BUILD_TYPE="$BUILD_TYPE MESA"
else
- if test "$with_x" != "no"; then
+ if test "$USING_X11" = TRUE; then
ENABLE_OPENGL=TRUE
fi
ENABLE_OPENGL_CANVAS=TRUE