summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPeter Foley <pefoley2@pefoley.com>2016-01-18 14:40:59 -0500
committerjan iversen <jani@documentfoundation.org>2016-01-21 07:29:13 +0000
commitf78de4441508fc81b1e013b907903df9ac4fe664 (patch)
treeaa8fecfb922b944204f0188178f03bd8af86b145 /configure.ac
parent2879dceaf56df81734bf36e1d20c973de0a5aa29 (diff)
Fix visibility check for lto on android
Change-Id: I5eea41feca7d5ab8b9d104e8356dce8831883a48 Reviewed-on: https://gerrit.libreoffice.org/21585 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: jan iversen <jani@documentfoundation.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index d5ae425cbbdc..0f9fa82a5585 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6513,7 +6513,7 @@ __attribute__ ((visibility ("default"))) void TestFunc() {
TestStruct::Init();
}
_ACEOF
- if ! $CXX $CXXFLAGS $CPPFLAGS -fpic -S visibility.cxx 2>/dev/null > /dev/null; then
+ if ! $CXX $CXXFLAGS $CPPFLAGS -fpic -S visibility.cxx; then
gccvisbroken=yes
else
case "$host_cpu" in
@@ -6521,7 +6521,7 @@ _ACEOF
if test "$_os" = "Darwin" -o "$WITH_MINGW" = "yes"; then
gccvisbroken=no
else
- if $EGREP -q '@PLT|@GOT' visibility.s; then
+ if $EGREP -q '@PLT|@GOT' visibility.s || test "$ENABLE_LTO" = "TRUE"; then
gccvisbroken=no
else
gccvisbroken=yes