summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKhaled Hosny <khaledhosny@eglug.org>2016-12-02 08:06:08 +0200
committerKhaled Hosny <khaledhosny@eglug.org>2016-12-03 05:57:30 +0000
commitd63b9a335a83250b4e0dc4514f484f131f35fda2 (patch)
tree066b3f8dcb1da3fa8e2a9c01f86fff5e267ffaee /configure.ac
parent5e74df1c3a09bd00caa4f9b8d3d0cd5539d1acff (diff)
Require HarfBuzz 0.9.42
This is the first version where hb_buffer_set_cluster_level() was introduced. The layout engine depends on this feature in a few places and though we can build without it, the result will be wrong in some cases (i.e. any where we assume combining marks will have their own cluster number). Reviewed-on: https://gerrit.libreoffice.org/31521 Reviewed-by: Rene Engelhard <rene@debian.org> Reviewed-by: Khaled Hosny <khaledhosny@eglug.org> Tested-by: Khaled Hosny <khaledhosny@eglug.org> (cherry picked from commit b9fe5dc791f56df55495d171ae901a246907c68b) Change-Id: I89187f317052e7933b83ad0350cace239333510b Reviewed-on: https://gerrit.libreoffice.org/31572 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Khaled Hosny <khaledhosny@eglug.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 2dadc7c95886..9f5b029b4cdd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -9281,7 +9281,7 @@ AC_SUBST(ENABLE_ORCUS)
dnl ===================================================================
dnl HarfBuzz
dnl ===================================================================
-libo_CHECK_SYSTEM_MODULE([harfbuzz],[HARFBUZZ],[harfbuzz-icu >= 0.9.18],["-I${WORKDIR}/UnpackedTarball/harfbuzz/src"],["-L${WORKDIR}/UnpackedTarball/harfbuzz/src/.libs -lharfbuzz"])
+libo_CHECK_SYSTEM_MODULE([harfbuzz],[HARFBUZZ],[harfbuzz-icu >= 0.9.42],["-I${WORKDIR}/UnpackedTarball/harfbuzz/src"],["-L${WORKDIR}/UnpackedTarball/harfbuzz/src/.libs -lharfbuzz"])
if test "$COM" = "MSC"; then # override the above
HARFBUZZ_LIBS="${WORKDIR}/UnpackedTarball/harfbuzz/src/.libs/libharfbuzz.lib"
fi