summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLionel Elie Mamane <lionel@mamane.lu>2017-01-05 12:58:26 +0100
committerMichael Stahl <mstahl@redhat.com>2017-01-05 14:24:22 +0000
commitddc57a6915ed06ecbf2e89e8003e73a604fd4324 (patch)
treec791dbe3c200a23007fd0409dcb3db4b996ca928 /configure.ac
parentf463c4890df7677f157e5f8510f91225a76fc6ed (diff)
require firebird 3.0 for build (don't allow 2.5)
Keep firebird_integer_x64le.odb around for a future 3.x firebird that will allow opening Firebird 2.5 databases, so that we can test this capacity in our tests. Change-Id: I05dbef51284bdb25132ff6cb661659430eea6a92 (cherry picked from commit 860ecb9e583627ab43097784ad98b41afd983ff6) Reviewed-on: https://gerrit.libreoffice.org/32753 Reviewed-by: Michael Stahl <mstahl@redhat.com> Tested-by: Jenkins <ci@libreoffice.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 4 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index e7b149597ed5..29b1eee2ca9f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8711,28 +8711,20 @@ if test "$enable_firebird_sdbc" = "yes" ; then
if test -n "${FIREBIRD_VERSION}"; then
FIREBIRD_MAJOR=`echo $FIREBIRD_VERSION | cut -d"." -f1`
FIREBIRD_MINOR=`echo $FIREBIRD_VERSION | cut -d"." -f2`
- if test "$FIREBIRD_MAJOR" -eq "2" -a "$FIREBIRD_MINOR" -eq "5"; then
- AC_MSG_RESULT([OK])
- elif test "$FIREBIRD_MAJOR" -eq "3" -a "$FIREBIRD_MINOR" -eq "0"; then
- AC_DEFINE(HAVE_FIREBIRD_30, 1)
+ if test "$FIREBIRD_MAJOR" -eq "3" -a "$FIREBIRD_MINOR" -eq "0"; then
AC_MSG_RESULT([OK])
else
- AC_MSG_ERROR([Ensure firebird 2.5.x or 3.0.x is installed])
+ AC_MSG_ERROR([Ensure firebird 3.0.x is installed])
fi
else
__save_CFLAGS="${CFLAGS}"
CFLAGS="${CFLAGS} ${FIREBIRD_CFLAGS}"
AC_COMPILE_IFELSE([AC_LANG_SOURCE([[#include <ibase.h>
-#if defined(FB_API_VER) && FB_API_VER == 25
-int fb_api_is_25(void) { return 0; }
-#elif defined(FB_API_VER) && FB_API_VER == 30
+#if defined(FB_API_VER) && FB_API_VER == 30
int fb_api_is_30(void) { return 0; }
#else
#error "Wrong Firebird API version"
-#endif]])],AC_MSG_RESULT([OK]),AC_MSG_ERROR([Ensure firebird 2.5.x or 3.0.x is installed]))
- if nm conftest.$OBJEXT | grep fb_api_is_30; then
- AC_DEFINE(HAVE_FIREBIRD_30, 1)
- fi
+#endif]])],AC_MSG_RESULT([OK]),AC_MSG_ERROR([Ensure firebird 3.0.x is installed]))
CFLAGS="${__save_CFLAGS}"
fi
ENABLE_FIREBIRD_SDBC="TRUE"
@@ -8791,7 +8783,6 @@ AC_SUBST(LIBATOMIC_OPS_LIBS)
AC_SUBST(SYSTEM_FIREBIRD)
AC_SUBST(FIREBIRD_CFLAGS)
AC_SUBST(FIREBIRD_LIBS)
-AC_SUBST(HAVE_FIREBIRD_30)
AC_SUBST([TOMMATH_CFLAGS])
AC_SUBST([TOMMATH_LIBS])