summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@iki.fi>2013-04-03 21:04:16 +0300
committerTor Lillqvist <tml@iki.fi>2013-04-03 21:13:17 +0300
commit7aa6f1b01481c1d0f1a12f56ad197c797056c37b (patch)
tree3fa3525ad487c08a3e126b0eae6ef0822b25aa75 /configure.ac
parentd8842c2221cb5e6ea958381f9dcd76d9bb9bbafc (diff)
Remove Mac OS X for PowerPC support
Change-Id: I10b15141e6a5f93365e1cfa6fbc0c7cc3ea49b15
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 1 insertions, 17 deletions
diff --git a/configure.ac b/configure.ac
index abd069d83c15..a3f50aa50285 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2353,10 +2353,7 @@ dnl Check / find MacOSX SDK and compiler, version checks
dnl ===================================================================
if test "$_os" = "Darwin"; then
- if test "$build_cpu" = i386 -a "$host_cpu" = powerpc; then
- # Cross-compiling for PPC from Intel
- arch='-arch ppc'
- elif test "$enable_64_bit" = "" -o "$enable_64_bit" = "no"; then
+ if test "$enable_64_bit" = "" -o "$enable_64_bit" = "no"; then
bitness=-m32
else
bitness=-m64
@@ -3435,13 +3432,6 @@ darwin*)
OUTPATH=unxiosr
OS=IOS
;;
- powerpc*)
- CPU=P
- CPUNAME=POWERPC
- RTL_ARCH=PowerPC
- PLATFORMID=macosx_powerpc
- OUTPATH=unxmacxp
- ;;
i*86)
if test "$BITNESS_OVERRIDE" = 64; then
AC_MSG_ERROR([Can't build 64-bit code in 32-bit OS])
@@ -5078,12 +5068,6 @@ if test "$_os" != "WINNT" -o "$WITH_MINGW" = "yes"; then
],
[
case "$_os-$host_cpu" in
- Darwin-powerpc)
- test -z "$ac_cv_alignof_short" && ac_cv_alignof_short=1
- test -z "$ac_cv_alignof_int" && ac_cv_alignof_int=1
- test -z "$ac_cv_alignof_long" && ac_cv_alignof_long=1
- test -z "$ac_cv_alignof_double" && ac_cv_alignof_double=1
- ;;
Linux-i686)
test -z "$ac_cv_alignof_short" && ac_cv_alignof_short=2
test -z "$ac_cv_alignof_int" && ac_cv_alignof_int=4