summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2016-04-28 15:00:48 +0200
committerStephan Bergmann <sbergman@redhat.com>2016-04-28 15:00:48 +0200
commit786f29a9edf81cc85c62459b3ea2fd91646d4e56 (patch)
tree293f9d4dde072c11d205eae3d0926a381be9752f /configure.ac
parent26d73dbf53831cf4d5aec1f4db32bedb2c1e06be (diff)
Use COMPILER_PLUGINS_CXX during configure
Change-Id: I600a6b96a64fc82cde72200b78f60001a2dba82a
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index ae441cbe5b36..d331b426cb09 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6668,7 +6668,7 @@ if test "$COM_IS_CLANG" = "TRUE"; then
save_CXX=$CXX
# compiler plugins must be built with "native" bitness of clang
# because they link against clang libraries
- CXX=`echo $CXX | sed -e s/-m64// -e s/-m32//`
+ CXX=${COMPILER_PLUGINS_CXX-$(echo $CXX | sed -e s/-m64// -e s/-m32//)}
CPPFLAGS="$CPPFLAGS $CXXFLAGS_CXX11 -I$CLANGDIR/include -I$CLANGDIR/tools/clang/include -D__STDC_CONSTANT_MACROS -D__STDC_FORMAT_MACROS -D__STDC_LIMIT_MACROS"
AC_CHECK_HEADER(clang/AST/RecursiveASTVisitor.h,
[COMPILER_PLUGINS=TRUE],