summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@collabora.com>2015-10-12 16:22:31 +0300
committerMichael Stahl <mstahl@redhat.com>2015-10-27 15:25:07 +0000
commit446f17f6c1f98b17ceb6750f5dc67a27330d1351 (patch)
tree39215e4f5122c294674582838c48956f288bf555 /configure.ac
parentd00d5f6fe89fddb214aad2087d8352426c1c78d4 (diff)
Automating configure choices based on what is installed considered harmful
Don't automatically --disable-odk (if not mentioned explicitly either way) based on whether doxygen is found or not. Caolán says: It's an absolute pain as a maintainer when packages do that. You build it in some minimal build env and all is well, then some depend changes and something else ends up in the build env and now your package fails to build anymore, or behaves quite differently. Change-Id: I8bc6ab6f90e6e070a37e37b5108081425e116173 Reviewed-on: https://gerrit.libreoffice.org/19324 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Michael Stahl <mstahl@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 1 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 9e0be4189f82..062d5d332dca 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7335,11 +7335,7 @@ else
if test "$with_doxygen" = yes; then
AC_PATH_PROG([DOXYGEN], [doxygen])
if test -z "$DOXYGEN"; then
- if test "$enable_odk" = "" ; then
- enable_odk="no"
- else
- AC_MSG_ERROR([doxygen not found in \$PATH; specify its pathname via --with-doxygen=..., or disable its use via --without-doxygen])
- fi
+ AC_MSG_ERROR([doxygen not found in \$PATH; specify its pathname via --with-doxygen=..., or disable its use via --without-doxygen])
fi
else
AC_MSG_CHECKING([for doxygen])