summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Ostrovsky <david@ostrovsky.org>2016-02-20 10:30:21 +0100
committerMichael Stahl <mstahl@redhat.com>2016-02-22 17:19:23 +0100
commit2fe55445209695accbffc2fe75ee35ade86a8256 (patch)
tree8e022f23e47d90cb59f2b447790eab512561c9eb /configure.ac
parentbcaee2b0149651173cc93763231c47ff2f5a55c2 (diff)
Fix UCRT detection
Change-Id: If2ef7a8b507e9d65f1f1ee186491ce2f35340362 Reviewed-on: https://gerrit.libreoffice.org/22545 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Norbert Thiebaud <nthiebaud@gmail.com> (cherry picked from commit 3ff41a00aa25922be4cb71a657b124a1c4a8aef7) Signed-off-by: Michael Stahl <mstahl@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 5 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 299984b698a1..2163957ad720 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3478,13 +3478,14 @@ if test "$_os" = "WINNT"; then
if test -n "$ucrttest"; then
AC_MSG_RESULT([found])
PathFormat "$ucrttest"
- ucrtincpath_formatted="$formatted_path/Include/$ucrtdir/ucrt"
+ ucrtincpath_formatted="${formatted_path}Include/$ucrtdir/ucrt"
# SOLARINC is used for external modules and must be set too.
# And no, it's not sufficient to set SOLARINC only, as configure
# itself doesn't honour it.
SOLARINC="$SOLARINC -I$ucrtincpath_formatted"
CFLAGS="$CFLAGS -I$ucrtincpath_formatted"
- CXXFLAGS="$CPPFLAGS -I$ucrtincpath_formatted"
+ CXXFLAGS="$CXXFLAGS -I$ucrtincpath_formatted"
+ CPPFLAGS="$CPPFLAGS -I$ucrtincpath_formatted"
else
AC_MSG_ERROR([not found])
fi
@@ -12603,7 +12604,7 @@ if test "$build_os" = "cygwin"; then
fi
if test $VCVER = 140; then
PathFormat "$ucrttest"
- ucrtlibpath_formatted="$formatted_path/lib/$ucrtdir/ucrt/x64"
+ ucrtlibpath_formatted="${formatted_path}lib/$ucrtdir/ucrt/x64"
ILIB="$ILIB;$ucrtlibpath_formatted"
fi
else
@@ -12617,7 +12618,7 @@ if test "$build_os" = "cygwin"; then
fi
if test $VCVER = 140; then
PathFormat "$ucrttest"
- ucrtlibpath_formatted="$formatted_path/lib/$ucrtdir/ucrt/x86"
+ ucrtlibpath_formatted="${formatted_path}lib/$ucrtdir/ucrt/x86"
ILIB="$ILIB;$ucrtlibpath_formatted"
fi
fi