summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2015-02-05 17:56:38 +0100
committerStephan Bergmann <sbergman@redhat.com>2015-02-05 17:56:51 +0100
commitc7caa3b9a1977dc2f069939d1084791010d59334 (patch)
treee863a319b09db46dcbf9de668fb31b1d360da398 /configure.ac
parent231678b9816aeded19f372dfa8794a998dbc09f1 (diff)
Better error reporting
Change-Id: Ica81e236e205cbb994220015a51ffb1f98785bd6
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0ffc61c1db0f..950c7c8526c2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2857,6 +2857,8 @@ if test $_os = Darwin; then
MACOSX_CODESIGNING_IDENTITY=$identity
pretty_name=`security find-identity -p codesigning -v | grep "$MACOSX_CODESIGNING_IDENTITY" | sed -e 's/^[[^"]]*"//' -e 's/"//'`
AC_MSG_RESULT([yes, using the identity $MACOSX_CODESIGNING_IDENTITY for $pretty_name])
+ else
+ AC_MSG_ERROR([cannot determine identity to use])
fi
elif test -n "$enable_macosx_code_signing" -a "$enable_macosx_code_signing" != no ; then
MACOSX_CODESIGNING_IDENTITY=$enable_macosx_code_signing