summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNorbert Thiebaud <nthiebaud@gmail.com>2015-01-14 21:04:09 -0600
committerNorbert Thiebaud <nthiebaud@gmail.com>2015-01-15 06:21:24 +0000
commitbb79f1ef25887190f63abbbe24bc9900807f7613 (patch)
tree3d5cb20577bf19021f3478c28fa299d1b2d4d399 /configure.ac
parentd04e06f6e41250d51c931dd9aa160c7d1b83941b (diff)
enable-werror for LODE build
Change-Id: I4bcdeca96e59e2bc3a2a96f546d060504f020bc7 Reviewed-on: https://gerrit.libreoffice.org/13917 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Norbert Thiebaud <nthiebaud@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index d4029a5f5a34..ac3dc4e93f0c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4538,7 +4538,12 @@ if test -n "$enable_werror" -a "$enable_werror" != "no"; then
ENABLE_WERROR="TRUE"
AC_MSG_RESULT([yes])
else
- AC_MSG_RESULT([no])
+ if test -n "$LODE_HOME"; then
+ ENABLE_WERROR="TRUE"
+ AC_MSG_RESULT([yes])
+ else
+ AC_MSG_RESULT([no])
+ fi
fi
AC_SUBST(ENABLE_WERROR)