summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTomas Chvatal <tchvatal@suse.cz>2012-12-10 10:41:35 +0100
committerTomáš Chvátal <tchvatal@suse.cz>2013-01-10 15:54:48 +0100
commitf0fd3bd8f8a13f6cbe2a27018b83eee24a694c09 (patch)
tree98743b89a2b388cf57eb196d5070b8862b45a7bf /configure.ac
parent9299707ce09077f10c49ec836e26f6197ed20a1a (diff)
Add configure switch that allows hardlink deliver
This switch just makes possible to configure in ln delivery instead of cp based one. The feature was already in the place, we just make it visible as configure option now. Change-Id: I778ef3b03e6b9a57057e66ff6307e7da46bcd935
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 19 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b028e39cae26..9da5b39e6b07 100644
--- a/configure.ac
+++ b/configure.ac
@@ -651,6 +651,12 @@ AC_ARG_ENABLE(ext-wiki-publisher,
dnl ---------- *** ----------
+AC_ARG_ENABLE([hardlink-deliver],
+ AS_HELP_STRING([--enable-hardlink-deliver],
+ [Put files into deliver folder as hardlinks instead of copying them
+ over. Saves space and speeds up build.])
+)
+
AC_ARG_ENABLE(mergelibs,
AS_HELP_STRING([--enable-mergelibs],
[Enables linking of big, merged, library. Experimental feature tested
@@ -11986,6 +11992,19 @@ else
fi
AC_SUBST(MERGELIBS)
+# ===================================================================
+# Create hardlinks on deliver instead of copying for smaller size and speed up
+# ===================================================================
+AC_MSG_CHECKING([whether to create hardlinks for delivering files])
+HARDLINKDELIVER=
+if test "$enable_hardlink_deliver" = "yes"; then
+ HARDLINKDELIVER="TRUE"
+ AC_MSG_RESULT([yes])
+else
+ AC_MSG_RESULT([no])
+fi
+AC_SUBST(HARDLINKDELIVER)
+
dnl ===================================================================
dnl icerun is a wrapper that stops us spawning tens of processes
dnl locally - for tools that can't be executed on the compile cluster