summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@iki.fi>2013-02-14 12:00:11 +0200
committerMichael Meeks <michael.meeks@suse.com>2013-02-19 08:39:08 +0000
commitc56593f029b17f35672b0b01b269e6914f80cbdf (patch)
tree3587a51a77a55f8ec01edd3e312d2e72630f25ad /configure.ac
parent3d9911a925607ed58002c6c9488507bd5a818975 (diff)
Merge in Bluetooth code for the Impress Remote for OS X
Thirteen commits from master squashed into one commit. Original commit messages in order below, so note that claims are in many cases overridden by later commits. === This is the 1st commit message: Work in progress. It sets up the SDP service record and registers it, and that seems to work. Does not do anything with it yet. I wonder if the current approach to use the standard SerialPort service class will work for Macs, as they by default have one SerialPort service running, "Bluetooth-PDA-Sync", whatever that is. There is no code in the Android app to handle the case of there being several Serial Port services on the computer it wants to connect to, so what happens then when there are two will be interesting to see. (I can't find in the Android API any way to enumerate services that use the same service class. If there was, the app could choose the correct one based on its name.) So probably we should pretty soon switch to using a dedicated service class UUID instead of using the standard serial port one. As we already have the app out in the wild it will probably have to be modified to look for both Serial Port and our own service then? Sigh. === This is the 2nd commit message: Add this single-line file === This is the 3rd commit message: Fix build against Mac OS X SDK 10.4 === This is the 4th commit message: More work on the Impress Remote Control Bluetooth code for OS X Mostly the work of Thorsten, from December, adapted to compile against the current remote control code, and with one or two crucial things added. Plus lots of SAL_INFO calls added; once it works well many of them can be dropped. Does not work properly yet, do not cherry-pick just this to 4.0. === This is the 5th commit message: Nothing in the C standard about sockets === This is the 6th commit message: Fix compilation for Linux and hopefully Windows, too === This is the 7th commit message: Blind fix for WaE: class does not fully implement protocol The Xcode 3 compiler warns: class 'ChannelDelegate' does not fully implement the 'IOBluetoothRFCOMMChannelDelegate' protocol. === This is the 8th commit message: pragma GCC diagnostic is not available for 4.0.1 === This is the 9th commit message: std::vector::data() is C++11 === This is the 10th commit message: WaE: comparison is always true due to limited range of data type === This is the 11th commit message: Be specific in the logging as multiple threads involved Sure, each SAL_INFO output line includes the thread ID, but still, good to avoid confusion from where this line is coming. === This is the 12th commit message: Plug autorelease leak === This is the 13th commit message: Handle gracefully the remote end closing the RFCOMM channel Avoids a crash if one presses the "back" key on the Android remote control. (cherry picked from commit 100ac0876f1038aea7e7ef56f95d008ecc6aea3d) (cherry picked from commit c30e94a9cfc05ca8882fe78749b41207611910fb) (cherry picked from commit bc96a84370fb167ab2c63582c10535992f31768c) (cherry picked from commit f9685dc555cc79fe3a52caf9da39df37da750cd4) (cherry picked from commit dca5d2b1677ebffd1a4ff791c47b33a6252210b2) (cherry picked from commit bd6201ee4df1b7f54b1e768167a88ea5faa38fcc) (cherry picked from commit 05dbe2dda095aee2b595a29b95b5952acbe55e67) (cherry picked from commit c21916ad8a315a9dd7f23bf9aef0576975470a5a) (cherry picked from commit 730cff74c04dc6ec2cfc9cf9dcec172392f50616) (cherry picked from commit 21bec368ad670e368d4b5cadae1c07962710f115) (cherry picked from commit da3d37b968a79ff59fcc4103174b5b6bc3ec74c0) (cherry picked from commit b008101fd754b6b81c4f31e3079f01a21434601d) (cherry picked from commit 6ce04df28c8b5d6043340efe6fdc229b51dd8c36) Change-Id: Ic72b432b2174e2ad31225a1b5fa97c1a79330e48 Signed-off-by: Michael Meeks <michael.meeks@suse.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 69bb297796c9..8addb6e78f00 100644
--- a/configure.ac
+++ b/configure.ac
@@ -9337,7 +9337,7 @@ if test -n "$enable_sdremote" -a "$enable_sdremote" != "no"; then
# If not explicitly enabled or disabled, default
if test -z "$enable_sdremote_bluetooth"; then
case "$OS" in
- LINUX|WNT)
+ LINUX|MACOSX|WNT)
# Default to yes for these
enable_sdremote_bluetooth=yes
;;