summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTomáš Chvátal <tchvatal@suse.cz>2012-12-20 15:35:29 +0100
committerTomáš Chvátal <tchvatal@suse.cz>2012-12-23 13:38:01 +0100
commit343a92f18cb4069acca547d455fcbd9ce42815e1 (patch)
treea405eed24c83faa1bce23f3252f34ab970525186 /configure.ac
parentaa7b9f0da9e810ff165204d4c6a51633c177ac78 (diff)
Require icu 4.6 or later with system icu
Change-Id: I8c0da25a000e10d65479665a61be054fdb2486a5 Reviewed-on: https://gerrit.libreoffice.org/1453 Reviewed-by: David Tardon <dtardon@redhat.com> Tested-by: Tomáš Chvátal <tchvatal@suse.cz>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 2 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index 064a2e97dabb..b028e39cae26 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8109,7 +8109,6 @@ SYSTEM_GENCMN=
ICU_MAJOR=49
ICU_MINOR=1
ICU_MICRO=1
-ICU_RECLASSIFIED_CLOSE_PARENTHESIS="YES"
ICU_RECLASSIFIED_PREPEND_SET_EMPTY="YES"
ICU_RECLASSIFIED_CONDITIONAL_JAPANESE_STARTER="YES"
ICU_RECLASSIFIED_HEBREW_LETTER="YES"
@@ -8134,10 +8133,10 @@ if test "$with_system_icu" = "yes"; then
ICU_MINOR=`echo $ICU_VERSION | cut -d"." -f2`
ICU_MICRO=`echo $ICU_VERSION | cut -d"." -f3`
- if test "$ICU_MAJOR" -ge "4"; then
+ if test "$ICU_MAJOR" -ge "49" -o \( "$ICU_MAJOR" = "4" -a "$ICU_MINOR" -ge "6" \); then
AC_MSG_RESULT([OK, $ICU_VERSION])
else
- AC_MSG_ERROR([not suitable, only >= 4.0 supported currently])
+ AC_MSG_ERROR([not suitable, only >= 4.6 supported currently])
fi
if test "$cross_compiling" = "yes" -a \( "$with_system_icu_for_build" = "yes" -o "$with_system_icu_for_build" = "force" \); then
@@ -8172,11 +8171,6 @@ You can use --with-system-icu-for-build=force to use it anyway.])
if test -z "$SYSTEM_GENCMN"; then
AC_MSG_ERROR([\'gencmn\' not found in \$PATH, install the icu development tool \'gencmn\'])
fi
- if test "$ICU_MAJOR" -ge "49" -o \( "$ICU_MAJOR" = "4" -a "$ICU_MINOR" -ge "4" \); then
- ICU_RECLASSIFIED_CLOSE_PARENTHESIS="YES"
- else
- ICU_RECLASSIFIED_CLOSE_PARENTHESIS="NO"
- fi
if test "$ICU_MAJOR" -ge "49"; then
ICU_RECLASSIFIED_PREPEND_SET_EMPTY="YES"
else
@@ -8203,7 +8197,6 @@ AC_SUBST(SYSTEM_GENCMN)
AC_SUBST(ICU_MAJOR)
AC_SUBST(ICU_MINOR)
AC_SUBST(ICU_MICRO)
-AC_SUBST(ICU_RECLASSIFIED_CLOSE_PARENTHESIS)
AC_SUBST([ICU_RECLASSIFIED_CONDITIONAL_JAPANESE_STARTER])
AC_SUBST([ICU_RECLASSIFIED_HEBREW_LETTER])
AC_SUBST(ICU_RECLASSIFIED_PREPEND_SET_EMPTY)