summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Stahl <mstahl@redhat.com>2012-11-26 22:41:26 +0100
committerMichael Stahl <mstahl@redhat.com>2012-11-26 23:14:34 +0100
commit264c136697bed318b324aa7412f22778b3c7020d (patch)
tree4e65de812e0d79b93d10748b6bab099e59f8976c /configure.ac
parentbee01c825b77a57b39e1b6baea6b6fdf1f0052e5 (diff)
configure: check for Python2 >= 2.6 as well
Change-Id: I568dc7c83cf60f2782ac730dc5efcb0e4b8de8a2
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 572ec999f37a..061175e13588 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7455,10 +7455,11 @@ system)
#include <Python.h>
int main(int argc, char **argv) {
- if (PY_MAJOR_VERSION < 3 || (PY_MAJOR_VERSION >= 3 && PY_MINOR_VERSION >= 3)) return 0;
+ if ((PY_MAJOR_VERSION == 2 && PY_MINOR_VERSION >= 6) ||
+ (PY_MAJOR_VERSION == 3 && PY_MINOR_VERSION >= 3)) return 0;
else return 1;
}
- ]])],[AC_MSG_RESULT([ok])],[AC_MSG_ERROR([Python >= 3.3 is needed when building with Python 3])],[])
+ ]])],[AC_MSG_RESULT([ok])],[AC_MSG_ERROR([Python >= 3.3 is needed when building with Python 3, or Python >= 2.6 when building with Python 2])],[])
CFLAGS=$save_CFLAGS
AC_LANG_POP(C)