summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLuboš Luňák <l.lunak@collabora.com>2014-11-10 12:22:01 +0100
committerLuboš Luňák <l.lunak@collabora.com>2014-11-10 12:32:23 +0100
commit74a2fb369c9ca7b3b423723926626fb0760abb29 (patch)
tree38f1128cb82b7bb1da94561f834c7fbb17eda5e4 /configure.ac
parent447d523fa7c6c82476f9ee48e4b9c82cfad05c50 (diff)
Revert "Force --std=gnu89 for clang."
Explictly passing any CFLAGS to configure overrides (=disables) CFLAGS that would be used by default. So if this sets CFLAGS to just --std=gnu89, .c files will never be built with optimization or debuginfo. This reverts commit 3a4860a751980b566b44d57cde188292df5e8726.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 0 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index b1fada10f238..f47b06ac3ee8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3190,10 +3190,6 @@ if test "$GCC" = "yes"; then
AC_MSG_RESULT([Clang $CLANG_FULL_VERSION, $CLANGVER])
AC_DEFINE_UNQUOTED(CLANG_FULL_VERSION,$CLANG_FULL_VERSION)
fi
-
- # On Windows MSVC only supports C90 so force gnu89 (especially in clang) to
- # to catch potential gnu89/C90 incompatibilities locally.
- CFLAGS="$CFLAGS -std=gnu89"
fi
AC_SUBST(COM_GCC_IS_CLANG)