summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRiccardo Magliocchetti <riccardo.magliocchetti@gmail.com>2014-11-07 16:38:57 +0100
committerMichael Stahl <mstahl@redhat.com>2014-11-11 17:00:18 +0000
commit6914b17246f73595c1061502e432d55d9b47d744 (patch)
tree8d46d7cd34639c3874d1e69140b2bbe519618071 /configure.ac
parent6bf26bcd7ec0c2cbafb6f3950412f51f50b1e856 (diff)
configure: --enable-headless is dead long live --without-x
To avoid confusion with the --headless runtime option leverage --without-x for the headless build. Please note that build and code ifdefery naming is not changed. Change-Id: Iefdbc7ca5b4bb5627ebd2c78b4cedf44dce4ae5b Reviewed-on: https://gerrit.libreoffice.org/12303 Reviewed-by: Michael Stahl <mstahl@redhat.com> Tested-by: Michael Stahl <mstahl@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 8 insertions, 14 deletions
diff --git a/configure.ac b/configure.ac
index f47b06ac3ee8..3c61a70af008 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1190,12 +1190,6 @@ AC_ARG_ENABLE(kde4,
both KDE3 and KDE4.]),
,)
-AC_ARG_ENABLE(headless,
- AS_HELP_STRING([--enable-headless],
- [Disable building of GUIs to reduce dependencies. Useful for
- server usage. Work in progress, use only if you are hacking on
- it. Not related to the --headless option.]), ,)
-
AC_ARG_ENABLE(randr,
AS_HELP_STRING([--disable-randr],
[Disable RandR support in the vcl project.]),
@@ -4335,9 +4329,9 @@ solaris*)
;;
esac
-if test "$enable_headless" = "yes"; then
+if test "$with_x" = "no"; then
if test "$GUIBASE" != "unx"; then
- AC_MSG_ERROR([$host_os operating system is not suitable to build LibreOffice with --enable-headless])
+ AC_MSG_ERROR([$host_os operating system is not suitable to build LibreOffice with --without-x])
fi
GUIBASE=not-used
fi
@@ -4581,7 +4575,7 @@ if test $_os != "WINNT" -a $_os != "Darwin"; then
fi
AC_SUBST(ENABLE_OOENV)
-if test "$enable_headless" = "yes"; then
+if test "$with_x" = "no"; then
# be sure to do not mess with uneeded stuff
test_randr=no
test_xrender=no
@@ -8922,7 +8916,7 @@ AC_MSG_CHECKING([whether to plug browser plugins into LibreOffice documents])
# Obviously no such thing on iOS or Android. Also not possible when building
# 64-bit OS X code as the plugin code uses QuickTime and Carbon.
if test "$_os" != Android -a "$_os" != iOS -a $_os != Darwin -a \
- "$enable_headless" != yes -a "$enable_mpl_subset" != yes
+ "$with_x" != "no" -a "$enable_mpl_subset" != yes
then
AC_MSG_RESULT([yes])
ENABLE_NPAPI_FROM_BROWSER=TRUE
@@ -8937,7 +8931,7 @@ dnl ***************************************
dnl testing for X libraries and includes...
dnl ***************************************
WANT_X11="no"
-if test $_os != Darwin -a $_os != WINNT -a $_os != Android -a $_os != iOS -a "$enable_headless" != "yes"; then
+if test $_os != Darwin -a $_os != WINNT -a $_os != Android -a $_os != iOS -a "$with_x" != "no"; then
WANT_X11="yes"
AC_DEFINE(HAVE_FEATURE_X11)
fi
@@ -9805,7 +9799,7 @@ AC_SUBST(GTK3_CFLAGS)
AC_SUBST(ENABLE_GTK3)
AC_MSG_CHECKING([which VCLplugs shall be built])
-if test "$GUIBASE" != "unx" -o "$enable_headless" = "yes"; then
+if test "$GUIBASE" != "unx" -o "$with_x" = "no"; then
enable_gtk=no
fi
ENABLE_GTK=""
@@ -9850,7 +9844,7 @@ fi
AC_SUBST(ENABLE_KDE4)
ENABLE_HEADLESS=""
-if test "x$enable_headless" = "xyes"; then
+if test "x$with_x" = "xno"; then
ENABLE_HEADLESS="TRUE"
SCPDEFS="$SCPDEFS -DLIBO_HEADLESS"
R="headless"
@@ -10189,7 +10183,7 @@ if test -z "$enable_opengl"; then
# As such with some suitable minor tweaks the Mac OpenGL transitions code would presumably
# build fine for iOS, too, but let's leave that for later
enable_opengl=no
- elif test "$enable_headless" = "yes"; then
+ elif test "$with_x" = "no"; then
enable_opengl=no
else
enable_opengl=yes