summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Stahl <mstahl@redhat.com>2014-02-11 18:40:09 +0100
committerMichael Stahl <mstahl@redhat.com>2014-02-12 09:53:10 +0100
commitadddbbc4c6cfdcb120eb2f51ee3b88409a2d09b4 (patch)
treed6a4d6f0d56dc3e19188931add5cf642f6320589 /configure.ac
parent5c0e6d86a8c9566249df0c0a4bbecc1ca8124a64 (diff)
normalize values of SYSTEM_BOOST
Change-Id: I2fce6545d7f279e0e2d6f3ff53eee1ab82314135
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 90e43ce125d2..75e188afe561 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8738,7 +8738,7 @@ dnl ===================================================================
AC_MSG_CHECKING([which boost to use])
if test "$with_system_boost" = "yes"; then
AC_MSG_RESULT([external])
- SYSTEM_BOOST=YES
+ SYSTEM_BOOST=TRUE
AX_BOOST_BASE(1.47)
AX_BOOST_DATE_TIME
mingw_boost_date_time_dll=`echo $BOOST_DATE_TIME_LIB | sed -e 's/^-l//' -e 's/\.dll$//'`
@@ -8770,7 +8770,7 @@ if test "$with_system_boost" = "yes"; then
else
AC_MSG_RESULT([internal])
BUILD_TYPE="$BUILD_TYPE BOOST"
- SYSTEM_BOOST=NO
+ SYSTEM_BOOST=
fi
AC_SUBST(SYSTEM_BOOST)
@@ -9169,7 +9169,7 @@ if test -z "$enable_orcus" -o "$enable_orcus" != no; then
libo_CHECK_SYSTEM_MODULE([orcus],[ORCUS],[liborcus-0.6 >= 0.5.0])
if test "$with_system_orcus" != "yes"; then
- if test "$SYSTEM_BOOST" = "YES"; then
+ if test "$SYSTEM_BOOST" = "TRUE"; then
# ===========================================================
# Determine if we are going to need to link with Boost.System
# ===========================================================