summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Stahl <mstahl@redhat.com>2014-03-10 23:40:25 +0100
committerMichael Stahl <mstahl@redhat.com>2014-03-11 11:57:18 +0100
commit727e2e7190cf74db9933940285e36011de54d9a2 (patch)
treeb345e06de0667f7585e166329f5a1b689c222ab5 /configure.ac
parent593ff642838e7167e1f9ad935ece7bf79337e662 (diff)
normalize values of WITH_GALLERY_BUILD
... and remove the unimplemented "package" option. Change-Id: I2b0cfcdc040b653fe0c4cd061ae4e0d7f745068c
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 4 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 5ed0344c1df7..48cf9fa8149a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1371,9 +1371,8 @@ AC_ARG_WITH(linked-git,
AC_ARG_WITH(galleries,
AS_HELP_STRING([--with-galleries],
[Specify how galleries should be built. It is possible either to
- build these internally from source ("build"), or to (optionally
- download and) unpack them them from a package ("package"), or
- to disable them ("no")]),
+ build these internally from source ("build"),
+ or to disable them ("no")]),
)
AC_ARG_WITH(theme,
@@ -2401,11 +2400,8 @@ dnl ===================================================================
AC_MSG_CHECKING([how to build and package galleries])
if test -n "${with_galleries}"; then
if test "$with_galleries" = "build"; then
- WITH_GALLERY_BUILD=YES
+ WITH_GALLERY_BUILD=TRUE
AC_MSG_RESULT([build from source images internally])
- elif test "$with_galleries" = "package"; then
- WITH_GALLERY_BUILD=PACKAGE
- AC_MSG_ERROR([FIXME - implement build from pre-compiled package])
elif test "$with_galleries" = "no"; then
WITH_GALLERY_BUILD=
AC_MSG_RESULT([disable non-internal gallery build])
@@ -2414,7 +2410,7 @@ if test -n "${with_galleries}"; then
fi
else
if test $_os != iOS -a $_os != Android; then
- WITH_GALLERY_BUILD=YES
+ WITH_GALLERY_BUILD=TRUE
AC_MSG_RESULT([internal src images for desktop])
else
WITH_GALLERY_BUILD=