summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMarkus Mohrhard <markus.mohrhard@collabora.co.uk>2014-03-03 10:49:37 +0100
committerMarkus Mohrhard <markus.mohrhard@googlemail.com>2014-03-03 10:56:28 +0100
commit69e14b0fee1c474168d8159b874d7c2fd9dea64f (patch)
tree36413d0601e7c38e223a80a8585d26d930259930 /configure.ac
parent1c3c83e6a35ee4258c9d658494297d1453a70806 (diff)
add experimental export file validation
In calc unit tests we validate the exported OOXML files now with officeotron. For this there must be a script called officeotron that takes the file path. Currently the generated files are still invalid but I'm going to fix it. Change-Id: I1809b9457a535dbbe6a72f3778dfb53db168bbda
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 20 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4d980716d9ae..bf2d03c046ad 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1835,6 +1835,15 @@ AC_ARG_WITH(ant-home,
],
,)
+AC_ARG_WITH(export-validation,
+ AS_HELP_STRING([--with-export-validation],
+ [If you want the exported files to be validated. Right now limited to OOXML files in calc export tests.
+ Note: You need an executable script officeotron that takes the path to the file.])
+ [
+ Usage: --with-export-validation
+ ],
+,)
+
AC_ARG_WITH(junit,
AS_HELP_STRING([--with-junit],
[Specifies the JUnit 4 jar file to use for JUnit-based tests.
@@ -2558,6 +2567,17 @@ dnl ENABLE_JAVA="TRUE" if we want there to be *run-time* (and build-time) suppor
dnl ENABLE_JAVA="" indicate no Java support at all
dnl ===================================================================
+dnl Export file validation
+dnl ===================================================================
+AC_MSG_CHECKING([whether to enable export file validation])
+if test "with_export_validation" != "no"; then
+ AC_MSG_RESULT([yes])
+ AC_DEFINE(HAVE_EXPORT_VALIDATION)
+else
+ AC_MSG_RESULT([no])
+fi
+
+dnl ===================================================================
dnl Test the Solaris compiler version
dnl ===================================================================
if test "$_os" = "SunOS"; then