summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@collabora.com>2014-06-06 17:39:04 +0300
committerTor Lillqvist <tml@collabora.com>2014-06-08 11:27:41 +0300
commit7b743040d2b7c32901f551566d5fd9df8a51b0c3 (patch)
tree9011221b065e2d70ccba2863b57ec8ac67c1c332 /configure.ac
parent7443479e5cb50d5aaf2311bd4d140719b986d17b (diff)
PackageMaker does not exist any more
Change-Id: Iefd1980fc87daa709e8e5c833407c2595e71b401
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 3 insertions, 16 deletions
diff --git a/configure.ac b/configure.ac
index d6a67e4279da..f9a08aa13922 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1467,7 +1467,7 @@ AC_ARG_WITH(package-format,
[Specify package format(s) for LibreOffice installation sets. The
implicit --without-package-format leads to no installation sets being
generated. Possible values: aix, archive, bsd, deb, dmg,
- installed, msi, native, osx, pkg, portable, and rpm.
+ installed, msi, native, pkg, portable, and rpm.
Example: --with-package-format='deb rpm']),
,)
@@ -4552,14 +4552,13 @@ AC_MSG_CHECKING([which package format to use])
if test -n "$with_package_format" -a "$with_package_format" != no; then
for i in $with_package_format; do
case "$i" in
- aix | bsd | deb | osx | pkg | rpm | native | portable | archive | dmg | installed | msi)
+ aix | bsd | deb | pkg | rpm | native | portable | archive | dmg | installed | msi)
;;
*)
AC_MSG_ERROR([unsupported format $i. Supported by EPM are:
aix - AIX software distribution
bsd - FreeBSD, NetBSD, or OpenBSD software distribution
deb - Debian software distribution
-osx - MacOS X software distribution
pkg - Solaris software distribution
rpm - RedHat software distribution
native - "Native" software distribution for the platform
@@ -7351,18 +7350,6 @@ if test "$enable_epm" = "yes"; then
AC_MSG_ERROR([dpkg needed for deb creation. Install dpkg.])
fi
fi
- if echo "$PKGFORMAT" | $EGREP osx 2>&1 >/dev/null; then
- if test "$_os" = "Darwin"; then
- AC_MSG_CHECKING([for PackageMaker availability])
- if ! test -x /Developer/Applications/Utilities/PackageMaker.app/Contents/MacOS/PackageMaker; then
- AC_MSG_ERROR([not installed. Please install Apples Dev Tools])
- else
- AC_MSG_RESULT([ok])
- fi
- else
- AC_MSG_ERROR([PackageMaker needed to build OSX packages and you are not on OSX...])
- fi
- fi
if echo "$PKGFORMAT" | $EGREP rpm 2>&1 >/dev/null || \
echo "$PKGFORMAT" | $EGREP pkg 2>&1 >/dev/null; then
if test "$with_epm" = "no" -a "$_os" != "Darwin"; then
@@ -7401,7 +7388,7 @@ if test "$enable_epm" = "yes"; then
else
for i in $PKGFORMAT; do
case "$i" in
- aix | bsd | deb | osx | pkg | rpm | native | portable)
+ aix | bsd | deb | pkg | rpm | native | portable)
AC_MSG_ERROR(
[--with-package-format='$PKGFORMAT' requires --enable-epm])
;;