summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLuboš Luňák <l.lunak@collabora.com>2014-04-25 14:06:57 +0200
committerLuboš Luňák <l.lunak@collabora.com>2014-04-25 14:18:07 +0200
commit508337db0c53caa5fb43ef26f781df159497a482 (patch)
treee9102ecd9e0d5924ae5a6643d4bc6ee7ba1adc10 /configure.ac
parent65a3622148ea67744c9c1fc18c2b8d48e5f1c79f (diff)
add better info on the Qt patches needed for KFileDialog
Change-Id: I1902f962ac03b171c5e7a45d9c8e59450b04418f
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 18 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 507678adb3f4..d377325a20d6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -11243,6 +11243,8 @@ int main(int argc, char **argv) {
AC_DEFINE(KDE_HAVE_GLIB,1)
KDE_GLIB_CFLAGS=$(printf '%s' "$KDE_GLIB_CFLAGS" | sed -e "s/-I/${ISYSTEM?}/g")
+ qt4_fix_warning=
+
AC_LANG_PUSH([C++])
save_CXXFLAGS=$CXXFLAGS
CXXFLAGS="$CXXFLAGS $KDE4_CFLAGS"
@@ -11269,7 +11271,12 @@ int main(int argc, char *argv[])
AC_MSG_RESULT([yes])
],[
AC_MSG_RESULT([no])
- AC_MSG_WARN([native KDE4 file pickers will be disabled at runtime - fix your Qt4 library!])
+ AC_MSG_WARN([native KDE4 file pickers will be disabled at runtime])
+ if test -z "$qt4_fix_warning"; then
+ add_warning "native KDE4 file pickers will be disabled at runtime, Qt4 fixes needed"
+ fi
+ qt4_fix_warning=1
+ add_warning " https://bugreports.qt-project.org/browse/QTBUG-37380 (needed)"
])
# Remove meta object data
@@ -11296,12 +11303,21 @@ int main(int argc, char *argv[])
AC_MSG_RESULT([yes])
],[
AC_MSG_RESULT([no])
- AC_MSG_WARN([native KDE4 file pickers will be disabled at runtime - fix your Qt4 library!])
+ AC_MSG_WARN([native KDE4 file pickers will be disabled at runtime])
+ if test -z "$qt4_fix_warning"; then
+ add_warning "native KDE4 file pickers will be disabled at runtime, Qt4 fixes needed"
+ fi
+ qt4_fix_warning=1
+ add_warning " https://bugreports.qt-project.org/browse/QTBUG-34614 (needed)"
])
# Remove meta object data
rm -f "${TSTBASE}."*
+ if test -n "$qt4_fix_warning"; then
+ add_warning " https://bugreports.qt-project.org/browse/QTBUG-38585 (recommended)"
+ fi
+
LIBS=$save_LIBS
CXXFLAGS=$save_CXXFLAGS
AC_LANG_POP([C++])