summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@collabora.com>2014-06-02 23:44:23 +0300
committerTor Lillqvist <tml@collabora.com>2014-06-11 09:29:02 +0300
commit285607d73a354e72066787dfac05079793270714 (patch)
tree865542e382b928a06ecb48d5edd7cf6a915e841a /configure.ac
parentd373afca4fc43259e39eac01f679f28411271905 (diff)
Accept the OS X 10.10 SDK
Change-Id: Ic9c210e51f9f6b776e77988fdb1c719ee3d9d73a
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 14 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index d2ffa7de6f39..3eba31da0fb0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2760,8 +2760,11 @@ if test $_os = Darwin; then
10.9)
MACOSX_SDK_VERSION=1090
;;
+ 10.10)
+ MACOSX_SDK_VERSION=101000
+ ;;
*)
- AC_MSG_ERROR([with-macosx-sdk $with_macosx_sdk is not a supported value, supported values are 10.5--9])
+ AC_MSG_ERROR([with-macosx-sdk $with_macosx_sdk is not a supported value, supported values are 10.5--10])
;;
esac
@@ -2813,7 +2816,7 @@ if test $_os = Darwin; then
fi
fi
;;
- 10.8|10.9)
+ 10.8|10.9|10.10)
xcodepath="`xcode-select -print-path`"
if test -d "$xcodepath/Platforms/MacOSX.platform/Developer/SDKs/MacOSX$with_macosx_sdk.sdk"; then
MACOSX_SDK_PATH="$xcodepath/Platforms/MacOSX.platform/Developer/SDKs/MacOSX$with_macosx_sdk.sdk"
@@ -2862,8 +2865,11 @@ if test $_os = Darwin; then
10.9)
MAC_OS_X_VERSION_MIN_REQUIRED="1090"
;;
+ 10.10)
+ MAC_OS_X_VERSION_MIN_REQUIRED="101000"
+ ;;
*)
- AC_MSG_ERROR([with-macosx-version-min-required $with_macosx_version_min_required is not a supported value, supported values are 10.5--9])
+ AC_MSG_ERROR([with-macosx-version-min-required $with_macosx_version_min_required is not a supported value, supported values are 10.5--10])
;;
esac
@@ -2925,7 +2931,7 @@ if test $_os = Darwin; then
INSTALL_NAME_TOOL=`xcrun -find install_name_tool`
LIBTOOL=libtool
;;
- 10.7|10.8|10.9)
+ 10.7|10.8|10.9|10.10)
if test "$enable_libc__" = yes; then
if test "$with_macosx_version_min_required" = 10.6; then
AC_MSG_ERROR([--enable-libc++ requires --with-macosx-version-min-required >= 10.7])
@@ -2965,8 +2971,11 @@ if test $_os = Darwin; then
10.9)
MAC_OS_X_VERSION_MAX_ALLOWED="1090"
;;
+ 10.10)
+ MAC_OS_X_VERSION_MAX_ALLOWED="101000"
+ ;;
*)
- AC_MSG_ERROR([with-macosx-version-max-allowed $with_macosx_version_max_allowed is not a supported value, supported values are 10.5--9])
+ AC_MSG_ERROR([with-macosx-version-max-allowed $with_macosx_version_max_allowed is not a supported value, supported values are 10.5--10])
;;
esac