summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRene Engelhard <rene@debian.org>2014-08-05 20:05:35 +0200
committerZolnai Tamás <tamas.zolnai@collabora.com>2014-08-29 14:05:19 +0200
commit2378f45d70c9ce4a093fd6b09216c1cd4563ebe2 (patch)
tree0ecb0396b1eec8f05092af6e98117d5d044355d1 /configure.ac
parent671083ca561345a202383f940c0456edba03c318 (diff)
implement --with-system-gltf
Change-Id: Ic842006b28f8043bcbbaa81ab5a20e15aa52ac82 (cherry picked from commit 97bda8e081fd746e9ef743b165b5bf621fc21fbb)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 14 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 02791cab2fc9..63e067bb4e9c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1552,6 +1552,11 @@ AC_ARG_WITH(system-jpeg,
[Use jpeg already on system.]),,
[with_system_jpeg=auto])
+AC_ARG_WITH(system-libgltf,
+ AS_HELP_STRING([--with-system-libgltf],
+ [Use libgltf already on system.]),,
+ [with_system_libgltf=auto])
+
AC_ARG_WITH(system-clucene,
AS_HELP_STRING([--with-system-clucene],
[Use clucene already on system.]),,
@@ -10561,7 +10566,12 @@ if test "x$enable_gltf" != "xno" -a $_os != Darwin -a $_os != iOS -a $_os != And
ENABLE_GLTF=TRUE
AC_MSG_RESULT([yes])
AC_DEFINE(HAVE_FEATURE_GLTF,1)
- BUILD_TYPE="$BUILD_TYPE LIBGLTF"
+ if test "$with_system_libgltf" = "yes"; then
+ SYSTEM_LIBGLTF=TRUE
+ PKG_CHECK_MODULES( LIBGLTF, libgltf-0.0 )
+ else
+ BUILD_TYPE="$BUILD_TYPE LIBGLTF"
+ fi
# otherwise build fails in collada2gltf external because of std::shared_ptr
if test "$have_std_shared_ptr" = "yes"; then
BUILD_TYPE="$BUILD_TYPE COLLADA2GLTF"
@@ -10570,6 +10580,9 @@ else
AC_MSG_RESULT([no])
fi
AC_SUBST(ENABLE_GLTF)
+AC_SUBST(SYSTEM_LIBGLTF)
+AC_SUBST(LIBGLTF_CFLAGS)
+AC_SUBST(LIBGLTF_LIBS)
# pdf import?
AC_MSG_CHECKING([whether to build the PDF import feature])