summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNorbert Thiebaud <nthiebaud@gmail.com>2013-08-31 18:55:53 -0500
committerNorbert Thiebaud <nthiebaud@gmail.com>2013-10-17 03:54:05 +0000
commitbf6d1f77420dcc9ece4d9f4eae1e37b427d85c6a (patch)
tree8147c75b761cc8d0546d34813ef1dc90256aa4f8 /configure.ac
parentce40605a8f906ebb4d800798d1e0c17ded4c053a (diff)
Normalize DISABLE_OPENSSL to USE TRUE/<nothing>
Change-Id: I84dd99f42e032315fbf31332dfb62eb3ef4aa4c0 Reviewed-on: https://gerrit.libreoffice.org/5724 Tested-by: LibreOffice gerrit bot <gerrit@libreoffice.org> Reviewed-by: Norbert Thiebaud <nthiebaud@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 00419d6798f8..42dfd441ee98 100644
--- a/configure.ac
+++ b/configure.ac
@@ -9249,7 +9249,7 @@ fi
dnl ===================================================================
dnl Check for system openssl
dnl ===================================================================
-DISABLE_OPENSSL="NO"
+DISABLE_OPENSSL=
AC_MSG_CHECKING([whether to disable OpenSSL usage])
if test "$enable_openssl" = "yes"; then
AC_MSG_RESULT([no])
@@ -9290,7 +9290,7 @@ if test "$enable_openssl" = "yes"; then
fi
else
AC_MSG_RESULT([yes])
- DISABLE_OPENSSL=YES
+ DISABLE_OPENSSL=TRUE
# warn that although OpenSSL is disabled, system libraries may be depending on it
AC_MSG_WARN([OpenSSL has been disabled. No code compiled by LibO will make use of it but system librares may create indirect dependencies])