summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBenedikt Morbach <benedikt.morbach@googlemail.com>2013-10-04 13:40:17 +0200
committerTor Lillqvist <tml@collabora.com>2013-10-04 11:57:57 +0000
commit43d1b80a6758022c2187e077f50f3606dbe557bf (patch)
tree0c14935b05b3e8d320ddd53dbe3c615875682d24 /configure.ac
parent2997d7d10a79917495a310135f863bd71541b304 (diff)
configure.ac: always search for md5sum
Since edf8db717f49199833de9fc9d2c9817bab613795, the MD5SUM env variable is used by solenv/bin/modules/{installer.pm,installer/systemactions.pm} like this: echo $languagestring | $ENV{'MD5SUM'} | sed -e "s/ .*//g" Because the MD5SUM check is behind "$enable_fetch_external" != "no", this causes an error with --disable-fetch external: sh: -c: line 0: syntax error near unexpected token `|' Move it out of the enable_fetch_external check. Change-Id: Ib0a9694226deed3957868c17fe4d982f38fd84b1 Reviewed-on: https://gerrit.libreoffice.org/6127 Reviewed-by: Tor Lillqvist <tml@collabora.com> Tested-by: Tor Lillqvist <tml@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 11 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 31988cd217c4..1cd7c0223549 100644
--- a/configure.ac
+++ b/configure.ac
@@ -11992,10 +11992,9 @@ AC_SUBST(OOO_JUNIT_JAR)
AC_SUBST(SCPDEFS)
#
-# check for wget and md5sum
+# check for wget and curl
#
WGET=
-MD5SUM=
CURL=
if test "$enable_fetch_external" != "no"; then
@@ -12015,6 +12014,16 @@ if test -z "$WGET" -a -z "$CURL"; then
AC_MSG_ERROR([neither wget nor curl found!])
fi
+fi
+
+AC_SUBST(WGET)
+AC_SUBST(CURL)
+
+#
+# check for md5sum
+#
+MD5SUM=
+
for i in md5 md5sum /usr/local/bin/md5sum gmd5sum /usr/sfw/bin/md5sum /opt/sfw/bin/gmd5sum /opt/local/bin/md5sum; do
if test "$i" = "md5"; then
eval "$i -x" > /dev/null 2>&1
@@ -12040,10 +12049,6 @@ if test -z "$MD5SUM"; then
AC_MSG_ERROR([no md5sum: found!])
fi
-fi
-
-AC_SUBST(WGET)
-AC_SUBST(CURL)
AC_SUBST(MD5SUM)
dnl ===================================================================