summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@collabora.com>2013-10-10 20:29:50 +0300
committerTor Lillqvist <tml@collabora.com>2013-10-11 13:15:03 +0300
commit22bdb75a7a133c37b22b4a26b52f18f008ea44d4 (patch)
tree9881a61afce1db50b2356e4c241e5c6267207ff6 /configure.ac
parent23df408dec36acb6fb6e96de14874fc2a42b7268 (diff)
Changes for iOS SDK 7.0
When building for the iOS Simulator, the -mios-simulator-min-version switch should be used, not -mmacosx-version-min. Change-Id: Icaf184b99d6b6160786b7a9de2fe475251d244cf
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac49
1 files changed, 32 insertions, 17 deletions
diff --git a/configure.ac b/configure.ac
index 37683da253e4..f45152e20db9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2903,15 +2903,43 @@ if test $_os = iOS; then
AC_MSG_CHECKING([what iOS SDK to use])
+ if test "$enable_ios_simulator" = yes; then
+ platform=iPhoneSimulator
+ else
+ platform=iPhoneOS
+ fi
+
xcode_developer=`xcode-select -print-path`
+ pref_sdk_ver=7.0
+ for sdkver in 7.0 6.1 6.0; do
+ t=$xcode_developer/Platforms/$platform.platform/Developer/SDKs/$platform$sdkver.sdk
+ if test -d $t; then
+ sysroot=$t
+ break
+ fi
+ done
+
+ if test -z "$sysroot"; then
+ AC_MSG_ERROR([Could not find iOS SDK, expected something like $xcode_developer/Platforms/$platform.platform/Developer/SDKs/${platform}${pref_sdk_ver}])
+ fi
+
+ AC_MSG_RESULT($sysroot)
+
if test "$enable_ios_simulator" = yes; then
- platform=iPhoneSimulator
- versionmin=-mmacosx-version-min=10.7
if test "$BITNESS_OVERRIDE" = 64; then
arch=x86_64
+ versionmin=-mios-simulator-version-min=7.0
else
arch=i386
+ case $sdkver in
+ 7.*)
+ versionmin=-mios-simulator-version-min=5.0
+ ;;
+ *)
+ versionmin=-mmacosx-version-min=10.7
+ ;;
+ esac
fi
else
platform=iPhoneOS
@@ -2924,21 +2952,8 @@ if test $_os = iOS; then
fi
fi
- pref_sdk_ver=6.1
- for I in 6.1 6.0 7.0; do
- t=$xcode_developer/Platforms/$platform.platform/Developer/SDKs/$platform$I.sdk
- if test -d $t; then
- sysroot=$t
- break
- fi
- done
-
- if test -z "$sysroot"; then
- AC_MSG_ERROR([Could not find iOS SDK, expected something like $xcode_developer/Platforms/$platform.platform/Developer/SDKs/${platform}${pref_sdk_ver}])
- fi
-
- AC_MSG_RESULT($sysroot)
-
+ # LTO is not really recommended for iOS builds,
+ # the link time will be astronomical
if test "$ENABLE_LTO" = TRUE; then
lto=-flto
fi