summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tlillqvist@suse.com>2012-12-23 01:51:57 +0200
committerTor Lillqvist <tlillqvist@suse.com>2012-12-23 01:55:22 +0200
commit19340f79a8e8fbd291d1b431848ad7c44aacded3 (patch)
tree6acb8da1089b6f32574704be5f0815c048ad214a /configure.ac
parent305ccd4f4754e47de021b38081729c30f161bef5 (diff)
We only build for Windows on Cygwin
It is pointless to test for both $build_os = cygwin and $_os = WINNT. Change-Id: I89b5196439f79284ca1a3fb08369decf20810b5b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 83def27bc473..3ecce6c69f03 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5986,7 +5986,7 @@ dnl ===================================================================
if test "$SOLAR_JAVA" != ""; then
# Windows-specific tests
- if test "$build_os" = "cygwin" -a "$_os" = "WINNT"; then
+ if test "$build_os" = "cygwin"; then
if test "$BITNESS_OVERRIDE" = 64; then
bitness="64-bit"
otherbitness="32-bit"
@@ -6029,7 +6029,7 @@ if test "$SOLAR_JAVA" != ""; then
fi
fi
- if test "$build_os" = "cygwin" -a "$_os" = "WINNT"; then
+ if test "$build_os" = "cygwin"; then
# Check that the JDK found is correct architecture
# Why is this necessary, we don't link with any library from the JDK I think,
@@ -6159,7 +6159,7 @@ if test "$SOLAR_JAVA" != ""; then
if test -z "$JAVACOMPILER"; then
AC_MSG_ERROR([$javacompiler not found set with_jdk_home])
fi
- if test "$build_os" = "cygwin" -a "$_os" = "WINNT"; then
+ if test "$build_os" = "cygwin"; then
if test x`echo "$JAVACOMPILER" | $GREP -i '\.exe$'` = x; then
JAVACOMPILER="${JAVACOMPILER}.exe"
fi
@@ -6215,7 +6215,7 @@ if test "$SOLAR_JAVA" != ""; then
if test -z "$JAVADOC"; then
AC_MSG_ERROR([$_javadoc_path not found set with_jdk_home])
fi
- if test "$build_os" = "cygwin" -a "$_os" = "WINNT"; then
+ if test "$build_os" = "cygwin"; then
if test x`echo "$JAVADOC" | $GREP -i '\.exe$'` = x; then
JAVADOC="${JAVADOC}.exe"
fi